summaryrefslogtreecommitdiff
path: root/dev-util/perf/perf-6.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-10 22:28:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-10 22:28:10 +0100
commitf2a91413828611d85d0496e98e1656e9b0e4528b (patch)
treeb3998888d687ece7d9aabfa86c9b449e5438a513 /dev-util/perf/perf-6.3-r1.ebuild
parentb98a1d0a0651765f29a8aeab25f904e730dfbf88 (diff)
gentoo auto-resync : 10:07:2023 - 22:28:10
Diffstat (limited to 'dev-util/perf/perf-6.3-r1.ebuild')
-rw-r--r--dev-util/perf/perf-6.3-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-util/perf/perf-6.3-r1.ebuild b/dev-util/perf/perf-6.3-r1.ebuild
index eb28c4419c9b..d519238f14e1 100644
--- a/dev-util/perf/perf-6.3-r1.ebuild
+++ b/dev-util/perf/perf-6.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit bash-completion-r1 estack llvm toolchain-funcs python-r1 linux-info
+inherit bash-completion-r1 estack flag-o-matic llvm toolchain-funcs python-r1 linux-info
DESCRIPTION="Userland tools for Linux Performance Counters"
HOMEPAGE="https://perf.wiki.kernel.org/"
@@ -231,6 +231,8 @@ perf_make() {
}
src_compile() {
+ filter-lto
+
# test-clang.bin not build with g++
if use clang; then
make -C "${S_K}/tools/build/feature" V=1 CXX=${CHOST}-clang++ test-clang.bin || die