summaryrefslogtreecommitdiff
path: root/dev-util/peg/peg-0.1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/peg/peg-0.1.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/peg/peg-0.1.9.ebuild')
-rw-r--r--dev-util/peg/peg-0.1.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/peg/peg-0.1.9.ebuild b/dev-util/peg/peg-0.1.9.ebuild
new file mode 100644
index 000000000000..6f8f2b50b211
--- /dev/null
+++ b/dev-util/peg/peg-0.1.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Recursive-descent parser generators for C"
+HOMEPAGE="http://piumarta.com/software/peg/"
+SRC_URI="http://piumarta.com/software/${PN}/${PF}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# FIXME: tests don't respect {C,LD}FLAGS and build stuff in runtime.
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/strip/d' \
+ -e '/^CFLAGS/d' \
+ -e 's/$(CFLAGS)/$(CFLAGS) $(LDFLAGS)/g' \
+ Makefile || die "sed failed"
+}
+
+src_install() {
+ mkdir -p "${D}/usr/bin" || die "mkdir failed"
+ emake ROOT="${D}" PREFIX="/usr" install
+ doman ${PN}.1
+}
+
+src_test() {
+ emake check
+ emake test
+}