summaryrefslogtreecommitdiff
path: root/dev-util/patchutils/patchutils-0.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/patchutils/patchutils-0.3.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/patchutils/patchutils-0.3.3.ebuild')
-rw-r--r--dev-util/patchutils/patchutils-0.3.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/patchutils/patchutils-0.3.3.ebuild b/dev-util/patchutils/patchutils-0.3.3.ebuild
new file mode 100644
index 000000000000..7cccfbdbbac7
--- /dev/null
+++ b/dev-util/patchutils/patchutils-0.3.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A collection of tools that operate on patch files"
+HOMEPAGE="http://cyberelk.net/tim/patchutils/"
+SRC_URI="http://cyberelk.net/tim/data/patchutils/stable/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+# The testsuite makes use of gendiff(1) that comes from rpm, thus if
+# the user wants to run tests, it should install that too.
+DEPEND="test? ( app-arch/rpm )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}