summaryrefslogtreecommitdiff
path: root/dev-util/patchelf/patchelf-0.18.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-24 00:08:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-24 00:08:50 +0100
commitb2523734e380d060074602eb5ce53daf7d98803b (patch)
tree0f6e9c0a8339a7e6bb0b44089507392951245899 /dev-util/patchelf/patchelf-0.18.0.ebuild
parent622b78d0d832282505f685f2f442c34ea0e8a7b1 (diff)
gentoo auto-resync : 24:04:2023 - 00:08:50
Diffstat (limited to 'dev-util/patchelf/patchelf-0.18.0.ebuild')
-rw-r--r--dev-util/patchelf/patchelf-0.18.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/patchelf/patchelf-0.18.0.ebuild b/dev-util/patchelf/patchelf-0.18.0.ebuild
new file mode 100644
index 000000000000..cbc25bb40a74
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.18.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://github.com/NixOS/patchelf"
+SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}