summaryrefslogtreecommitdiff
path: root/dev-util/patchelf/patchelf-0.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-util/patchelf/patchelf-0.11.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-util/patchelf/patchelf-0.11.ebuild')
-rw-r--r--dev-util/patchelf/patchelf-0.11.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/patchelf/patchelf-0.11.ebuild b/dev-util/patchelf/patchelf-0.11.ebuild
new file mode 100644
index 000000000000..ec5c769e0af3
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://nixos.org/patchelf.html"
+SRC_URI="https://nixos.org/releases/${PN}/${P}/${P}.tar.bz2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+
+S="${WORKDIR}/${P}.20200609.d6b2a72"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_test() {
+ emake check \
+ CFLAGS+=" -no-pie" \
+ CXXFLAGS+=" -no-pie"
+}