summaryrefslogtreecommitdiff
path: root/dev-util/patchbin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/patchbin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/patchbin')
-rw-r--r--dev-util/patchbin/Manifest4
-rw-r--r--dev-util/patchbin/metadata.xml18
-rw-r--r--dev-util/patchbin/patchbin-20160208.ebuild53
-rw-r--r--dev-util/patchbin/patchbin-99999999.ebuild53
4 files changed, 128 insertions, 0 deletions
diff --git a/dev-util/patchbin/Manifest b/dev-util/patchbin/Manifest
new file mode 100644
index 000000000000..dd5af9b8f8b9
--- /dev/null
+++ b/dev-util/patchbin/Manifest
@@ -0,0 +1,4 @@
+DIST patchbin-20160208.tar.gz 9713001 BLAKE2B 4ce3c5d43f7b0a909b5058b3877cecef68f703d803bcb6a4e4b7e907dedaab98cbe87f33a5211a318f8146e9ef4753da18d58b3cbc8e4ff715b58d82227ad7b6 SHA512 eeb5c4bc708cfc3a065568ef233297586c3bb3d497c6bf3ace52b8337b5a5d127e607f668a6f74e3be892e8cfac96a046dea3646735c4404efedd8760572353a
+EBUILD patchbin-20160208.ebuild 1113 BLAKE2B 15cc745c58f9af2a9e0724b5bb78d4c0e44eda3f52eee4f242a42f8ff94bf9c2023f3584717ed3a1b163290474971cbd575dc621be0a5fa6d17ec5793c15f97a SHA512 d4e8d1ffb09f910e88158fea92a82ae2606ee288d02ed636cc0fc932d9540d9b4b55d0baa58b81e51d9dd41ca1c7deaab7035fa852c629167bef2c4473ac6756
+EBUILD patchbin-99999999.ebuild 1115 BLAKE2B 14dce023dd58892cb6df213ba5ec2aa2c4ff8334c882023f85f79200902615b2d8c7b91e54cb9f4eb3e98730fe462ba5a609e3da2a5f2e31cc402517ab9882b2 SHA512 aefae56d63d80a27a2fdecc2743ea0406e1b495b78638e81459d3dd6102d3c07b0602d99a07dffed85c9948b1568a2d8522b3bd21e70425a8a21ade9b5110569
+MISC metadata.xml 528 BLAKE2B 566d71b86021dba9948978378279d2a4c95d50e4402c31c3da9bb3e1ab50d1d6148e104e3e3ea4c688a2bf1f720f3c4379d3eefc2eb57d316d9952d3f1e04409 SHA512 d15966f28c81025fd34bc247fc2f3f4ceda3c7dadd23f28487c80fe3155666665b9dd451e59356cd6bdcd30197be9a0439ab5c0b9383ab655870aa9033d58d94
diff --git a/dev-util/patchbin/metadata.xml b/dev-util/patchbin/metadata.xml
new file mode 100644
index 000000000000..1f33891b2670
--- /dev/null
+++ b/dev-util/patchbin/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>NP-Hardass@gentoo.org</email>
+ <name>NP-Hardass</name>
+ </maintainer>
+ <longdescription lang="en">
+ Apply binary patches without git
+ </longdescription>
+ <upstream>
+ <remote-id type="github">wine-compholio/wine-staging</remote-id>
+ <maintainer>
+ <name>Sebastian Lackner</name>
+ <email>sebastian@fds-team.de</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/patchbin/patchbin-20160208.ebuild b/dev-util/patchbin/patchbin-20160208.ebuild
new file mode 100644
index 000000000000..1f883b3bfbca
--- /dev/null
+++ b/dev-util/patchbin/patchbin-20160208.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wine-compholio/wine-staging"
+ KEYWORDS=""
+else
+ SHA="4ffcf184bb71c6c3512b3a8c144dcf4a3a76d23c"
+ SRC_URI="https://github.com/wine-compholio/wine-staging/archive/${SHA}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86 ~x86-fbsd"
+ S="${WORKDIR}/wine-staging-${SHA}"
+fi
+
+DESCRIPTION="Apply binary patches without git"
+HOMEPAGE="https://github.com/wine-compholio/wine-staging"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="userland_BSD userland_GNU"
+
+RDEPEND="
+ app-shells/bash
+ sys-apps/coreutils
+ sys-apps/gawk
+ sys-apps/grep
+ userland_BSD? (
+ sys-freebsd/freebsd-bin
+ sys-freebsd/freebsd-ubin
+ )
+ userland_GNU? (
+ sys-apps/util-linux
+ sys-devel/patch
+ )
+"
+
+src_prepare(){
+ mv patches/gitapply.sh ${PN} || die
+ sed -E -i "s/(\.\/)?gitapply(\.sh)?/${PN}/g" ${PN} || die
+
+ default
+}
+
+src_install(){
+ exeinto /usr/bin/
+ doexe ${PN}
+}
+
+pkg_postinst(){
+ einfo "${PN} can optionally use dev-util/git to apply patches if installed."
+}
diff --git a/dev-util/patchbin/patchbin-99999999.ebuild b/dev-util/patchbin/patchbin-99999999.ebuild
new file mode 100644
index 000000000000..3f22e8921aa8
--- /dev/null
+++ b/dev-util/patchbin/patchbin-99999999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wine-compholio/wine-staging"
+ KEYWORDS=""
+else
+ SHA="4ffcf184bb71c6c3512b3a8c144dcf4a3a76d23c"
+ SRC_URI="https://github.com/wine-compholio/wine-staging/archive/${SHA}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+ S="${WORKDIR}/wine-staging-${SHA}"
+fi
+
+DESCRIPTION="Apply binary patches without git"
+HOMEPAGE="https://github.com/wine-compholio/wine-staging"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="userland_BSD userland_GNU"
+
+RDEPEND="
+ app-shells/bash
+ sys-apps/coreutils
+ sys-apps/gawk
+ sys-apps/grep
+ userland_BSD? (
+ sys-freebsd/freebsd-bin
+ sys-freebsd/freebsd-ubin
+ )
+ userland_GNU? (
+ sys-apps/util-linux
+ sys-devel/patch
+ )
+"
+
+src_prepare(){
+ mv patches/gitapply.sh ${PN} || die
+ sed -E -i "s/(\.\/)?gitapply(\.sh)?/${PN}/g" ${PN} || die
+
+ default
+}
+
+src_install(){
+ exeinto /usr/bin/
+ doexe ${PN}
+}
+
+pkg_postinst(){
+ einfo "${PN} can optionally use dev-util/git to apply patches if installed."
+}