summaryrefslogtreecommitdiff
path: root/dev-util/pahole/pahole-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-19 05:58:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-19 05:58:32 +0000
commite1d95cd8c0944013a250bde528253138bffa2e65 (patch)
tree08cbcfc886960c44d0c296e7144f9fd430b3a838 /dev-util/pahole/pahole-9999.ebuild
parentd39fec05a2fac9978cd77634744637509744b561 (diff)
gentoo auto-resync : 19:01:2023 - 05:58:31
Diffstat (limited to 'dev-util/pahole/pahole-9999.ebuild')
-rw-r--r--dev-util/pahole/pahole-9999.ebuild41
1 files changed, 31 insertions, 10 deletions
diff --git a/dev-util/pahole/pahole-9999.ebuild b/dev-util/pahole/pahole-9999.ebuild
index 2b542cf4434e..5d98a672167d 100644
--- a/dev-util/pahole/pahole-9999.ebuild
+++ b/dev-util/pahole/pahole-9999.ebuild
@@ -1,19 +1,44 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake python-single-r1 git-r3
+inherit cmake python-single-r1
+
+MY_PN=dwarves
+MY_P=${MY_PN}-${PV}
DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/pahole/pahole.git"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/pahole/pahole.git"
+ inherit git-r3
+elif [[ ${PV} == *_p* ]] ; then
+ # Snapshots
+ #SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
+
+ # Patch rollups from git format-patch. Sometimes there are important
+ # fixes in git which haven't been released (and no release in sight).
+ # Patch rollups are a bit better for understanding where changes have
+ # come from for users.
+ SRC_URI="
+ http://fedorapeople.org/~acme/${MY_PN}/${MY_P%%_p*}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-patches.tar.xz
+ "
+ S="${WORKDIR}"/${MY_P%%_p*}
+else
+ SRC_URI="http://fedorapeople.org/~acme/${MY_PN}/${MY_P}.tar.xz"
+ S="${WORKDIR}"/${MY_P}
+fi
LICENSE="GPL-2" # only
SLOT="0"
-KEYWORDS=""
IUSE="debug"
+if [[ ${PV} != 9999 ]] ; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+fi
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
@@ -28,6 +53,8 @@ PATCHES=(
)
src_prepare() {
+ [[ -d "${WORKDIR}"/${P}-patches ]] && PATCHES+=( "${WORKDIR}"/${P}-patches )
+
cmake_src_prepare
python_fix_shebang ostra/ostra-cg ostra/python/ostra.py
}
@@ -36,9 +63,3 @@ src_configure() {
local mycmakeargs=( "-D__LIB=$(get_libdir)" )
cmake_src_configure
}
-
-src_test() { :; }
-
-src_install() {
- cmake_src_install
-}