summaryrefslogtreecommitdiff
path: root/dev-util/ostree/ostree-2018.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/ostree/ostree-2018.5.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/ostree/ostree-2018.5.ebuild')
-rw-r--r--dev-util/ostree/ostree-2018.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/ostree/ostree-2018.5.ebuild b/dev-util/ostree/ostree-2018.5.ebuild
new file mode 100644
index 000000000000..3c2aec24a4af
--- /dev/null
+++ b/dev-util/ostree/ostree-2018.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Operating system and container binary deployment and upgrades"
+HOMEPAGE="https://ostree.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/ostreedev/${PN}/releases/download/v${PV}/lib${P}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="grub selinux soup systemd zeroconf"
+RESTRICT="test"
+
+S="${WORKDIR}/lib${P}"
+COMMON_DEPEND="
+ app-arch/libarchive:=
+ app-arch/xz-utils:=
+ app-crypt/gpgme:=
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ dev-libs/openssl:=
+ net-misc/curl:=
+ sys-apps/util-linux:=
+ sys-fs/fuse:=
+ sys-libs/zlib:=
+
+ grub? ( sys-boot/grub:* )
+ selinux? ( sys-libs/libselinux:= )
+ soup? ( net-libs/libsoup:= )
+ systemd? ( sys-apps/systemd:= )
+ zeroconf? ( net-dns/avahi:* )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ sys-devel/bison
+ sys-devel/flex
+"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure() {
+ unset ${!XDG_*} #657346 g-ir-scanner sandbox violation
+ econf \
+ --with-crypto=openssl \
+ --with-curl \
+ --with-openssl \
+ $(use_with soup) \
+ $(use_with selinux ) \
+ $(use_with zeroconf avahi)
+}