summaryrefslogtreecommitdiff
path: root/dev-util/oprofile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-util/oprofile
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/Manifest3
-rw-r--r--dev-util/oprofile/files/gcc12.patch27
-rw-r--r--dev-util/oprofile/oprofile-1.4.0.ebuild1
3 files changed, 30 insertions, 1 deletions
diff --git a/dev-util/oprofile/Manifest b/dev-util/oprofile/Manifest
index ce61d883436f..bef0d4cd4dcf 100644
--- a/dev-util/oprofile/Manifest
+++ b/dev-util/oprofile/Manifest
@@ -1,4 +1,5 @@
+AUX gcc12.patch 904 BLAKE2B d71bd4c721f2720a54254bba39a5683c8e9945da31eb879f421f4d24c198334a3ec2a8eca3059a21152adec825e620f93398ba2bb49f503e233af653f8bb0e52 SHA512 4dcb8894ba19fd5fa03d5dcbc2f23933d5909cf4f1a325569020ad2d20ccdc7fb0e56fdb81d2856997dba1665f15cc591fd74ca1086770423c206cb3871618fa
AUX musl.patch 632 BLAKE2B fcaff5d665639ee365d51171024b98f58a431668dc36e829267ca7773b53b0efd1557f3e2366110685d673e2140e15855bee4220c6306a06d9ff1358bf6cbfd2 SHA512 fb9515de16bfa621fbb2f83a446b976ea8c123f779c2955a8740234310fdca66e1ea005d1c5a643b785ecf3797f658eec1a96b673b3cb534a55f30b182444a72
DIST oprofile-1.4.0.tar.gz 1557625 BLAKE2B fe1a725b713da0e06d3876c52f001163965c1b0dd8ccbb271ef6924525ac6ca342d55172c06cc21681b441c744780d5cb523be08562952c5916005ec67734221 SHA512 44c0ae55d20d623ea8b4245bfe3e208813dbb8778d7e320378ffe70538ef6af1a6ddaf5d110e29751c216879543f13121dd71cb320023205622b3f0cd6b157df
-EBUILD oprofile-1.4.0.ebuild 2018 BLAKE2B f80721f05dbd4fa4fdc219442ca36e5b4ea55d89237cdbde91e35305fb743b27acbe7a3748aa8b2466a581ce22cadc03b134cb493576e7474bb116e9b8ac4737 SHA512 0d27b9a67d9068461450c0497e082c2d47c385dd611c0cb5461a7bfe2a15c15c7be75839a178a918047e00c4fd2d0a5ebb52e7eec3e6e6c6e93f8324c86f6ad5
+EBUILD oprofile-1.4.0.ebuild 2052 BLAKE2B be1fdf0346db9e922ad27d542e483a970662c8a3e0dcd8985b6b31634e6abd662876e6971d83d15b19ecf273726367baade7b79cf16d78d0a92af696bed031a3 SHA512 af0c59fad980f849b03c352b79652b86298ee9786841097ecea00a85714421c9e0777cc27364d40a4055e96d03c236f90e2f92fdf66c3a3b808c2e55249da145
MISC metadata.xml 424 BLAKE2B 5a4c680f4d2201dbbecc1af9e7706c94d76b3a2400d2c8003d86578004762dac43340ec8d6f642db45da9ffa4723eb51c8e7f8f8f5887562ca4798b329944d2c SHA512 e6f305a38a8906a6cf493f8920caed471781ee0f54914625c5bb1fa5a0a0859f87aff56eeeaa6a85b54da36b3dc30ce2ac156d69e8535212933eab188058997e
diff --git a/dev-util/oprofile/files/gcc12.patch b/dev-util/oprofile/files/gcc12.patch
new file mode 100644
index 000000000000..96f56d6a7ea7
--- /dev/null
+++ b/dev-util/oprofile/files/gcc12.patch
@@ -0,0 +1,27 @@
+`gcc-12` will forbid std::string(nullptr_t) constructors
+(as they never had a defined behaviour):
+
+ operf_stats.cpp:182:24: error: use of deleted function 'std::__cxx11::basic_string...; std::nullptr_t = std::nullptr_t]'
+ 182 | return NULL;
+ | ^~~~
+
+Signed-off-by: Sergei Trofimovich <slyich@gmail.com>
+---
+ libperf_events/operf_stats.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libperf_events/operf_stats.cpp b/libperf_events/operf_stats.cpp
+index 3cc28a75..a7bd0aec 100644
+--- a/libperf_events/operf_stats.cpp
++++ b/libperf_events/operf_stats.cpp
+@@ -179,7 +179,7 @@ static string create_stats_dir(string const & cur_sampledir)
+ if (rc && (errno != EEXIST)) {
+ cerr << "Error trying to create stats dir. " << endl;
+ perror("mkdir failed with");
+- return NULL;
++ return "";
+ }
+ return stats_dir;
+ }
+--
+2.33.1
diff --git a/dev-util/oprofile/oprofile-1.4.0.ebuild b/dev-util/oprofile/oprofile-1.4.0.ebuild
index 2526034bec1b..8c623f03696c 100644
--- a/dev-util/oprofile/oprofile-1.4.0.ebuild
+++ b/dev-util/oprofile/oprofile-1.4.0.ebuild
@@ -47,6 +47,7 @@ pkg_setup() {
src_prepare() {
eapply "${FILESDIR}/musl.patch"
+ eapply "${FILESDIR}/gcc12.patch"
# bug 723092
sed -i 's/==/=/g' configure.ac || die