summaryrefslogtreecommitdiff
path: root/dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild')
-rw-r--r--dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild b/dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild
new file mode 100644
index 000000000000..917c0cad3500
--- /dev/null
+++ b/dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="OpenCL-Headers"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Unified C language headers for the OpenCL API"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-Headers"
+SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# To avoid file collisions in /usr/include/CL/
+DEPEND="!app-eselect/eselect-opencl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/include
+ doins -r "${S}"/CL
+}