summaryrefslogtreecommitdiff
path: root/dev-util/open-vcdiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-util/open-vcdiff
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/open-vcdiff')
-rw-r--r--dev-util/open-vcdiff/Manifest4
-rw-r--r--dev-util/open-vcdiff/files/open-vcdiff-0.8.4-gcc6.patch223
-rw-r--r--dev-util/open-vcdiff/metadata.xml8
-rw-r--r--dev-util/open-vcdiff/open-vcdiff-0.8.4-r1.ebuild24
4 files changed, 0 insertions, 259 deletions
diff --git a/dev-util/open-vcdiff/Manifest b/dev-util/open-vcdiff/Manifest
deleted file mode 100644
index ab0742cbe73c..000000000000
--- a/dev-util/open-vcdiff/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX open-vcdiff-0.8.4-gcc6.patch 8635 BLAKE2B 78abbc4df03d082ec936a6ddd2ff18d69acb15dd4bb4bc6628799c9b700afc049dde52f9941a5098a93ab37bff76da3eb6eeb1a22541a407e111b095654cae55 SHA512 f4b1ce46832bc279cc5fb421171f5efba64e1e733a1d733b8ed26d6b024e9e2875ab2dfffcecf3b48ab805c3f44ba9da3eb961fd36ebe5fa6beba3642177a368
-DIST open-vcdiff-0.8.4.tar.gz 780923 BLAKE2B 26e36866f8aab15e1103017e1ac2666634b5bdebf02738b5339dc31c283e643f4cbd75f58bff6a3d27965e568c6dd444dcf74655ce8abe1e1503f5f8424bd141 SHA512 fb9062d6a854c999d04eb68672596583e958c3d1705d58429280cb53dcf381c880b23d7fc9d5277545b4a5f9023435648d7bc87bad10cb30385fb950e5d499bd
-EBUILD open-vcdiff-0.8.4-r1.ebuild 510 BLAKE2B e1f6e4427453eb9a5f5c7a0deebd2fc009f20f8ad3ad89150646ec6694365ad80e9647b3aa2ab5f8225f46279f5f592aa94a8e6dd6745919661459ef1329ef52 SHA512 21c85520b16b17158ba09e3d9bc6b97079f5d19c32a946219ee5e3421c09f4b60af3e5adc1b5b4f47e5111551cdf3d0c159b6723862c5d4c8e3b243438ef6aea
-MISC metadata.xml 278 BLAKE2B a84e58dcfad537c763aea7363e551a386372db6961dc099bca0bd90a7c770b7004a91f4be5879c91c88b263435a27969222f7b37f72b41f91d5228c6f06259c4 SHA512 4b637493a5e196c76d1e2f560230f35b24549aa54088d0b718fa91c3ccb8631e6d30c49038bf19265f2fbe25dfd92247827827b576af5841fd061094bcea6f14
diff --git a/dev-util/open-vcdiff/files/open-vcdiff-0.8.4-gcc6.patch b/dev-util/open-vcdiff/files/open-vcdiff-0.8.4-gcc6.patch
deleted file mode 100644
index fdba3faa78b2..000000000000
--- a/dev-util/open-vcdiff/files/open-vcdiff-0.8.4-gcc6.patch
+++ /dev/null
@@ -1,223 +0,0 @@
---- a/src/vcdecoder_test.cc
-+++ b/src/vcdecoder_test.cc
-@@ -23,7 +23,7 @@
-
- namespace open_vcdiff {
-
--const char VCDiffDecoderTest::kStandardFileHeader[] = {
-+const uint8_t VCDiffDecoderTest::kStandardFileHeader[] = {
- 0xD6, // 'V' | 0x80
- 0xC3, // 'C' | 0x80
- 0xC4, // 'D' | 0x80
-@@ -31,7 +31,7 @@
- 0x00 // Hdr_Indicator: no custom code table, no compression
- };
-
--const char VCDiffDecoderTest::kInterleavedFileHeader[] = {
-+const uint8_t VCDiffDecoderTest::kInterleavedFileHeader[] = {
- 0xD6, // 'V' | 0x80
- 0xC3, // 'C' | 0x80
- 0xC4, // 'D' | 0x80
-@@ -61,21 +61,22 @@
- }
-
- void VCDiffDecoderTest::UseStandardFileHeader() {
-- delta_file_header_.assign(kStandardFileHeader,
-+ delta_file_header_.assign(reinterpret_cast<const char *>(kStandardFileHeader),
- sizeof(kStandardFileHeader));
- }
-
- void VCDiffDecoderTest::UseInterleavedFileHeader() {
-- delta_file_header_.assign(kInterleavedFileHeader,
-- sizeof(kInterleavedFileHeader));
-+ delta_file_header_.assign(
-+ reinterpret_cast<const char *>(kInterleavedFileHeader),
-+ sizeof(kInterleavedFileHeader));
- }
-
- void VCDiffDecoderTest::InitializeDeltaFile() {
- delta_file_ = delta_file_header_ + delta_window_header_ + delta_window_body_;
- }
-
--char VCDiffDecoderTest::GetByteFromStringLength(const char* s,
-- int which_byte) {
-+uint8_t VCDiffDecoderTest::GetByteFromStringLength(const char* s,
-+ int which_byte) {
- char varint_buf[VarintBE<int32_t>::kMaxBytes];
- VarintBE<int32_t>::Encode(static_cast<int32_t>(strlen(s)), varint_buf);
- return varint_buf[which_byte];
-@@ -101,10 +102,10 @@
- // (0x7FFFFFFF) at the given offset in the delta window.
- void VCDiffDecoderTest::WriteMaxVarintAtOffset(int offset,
- int bytes_to_replace) {
-- static const char kMaxVarint[] = { 0x87, 0xFF, 0xFF, 0xFF, 0x7F };
-+ static const uint8_t kMaxVarint[] = { 0x87, 0xFF, 0xFF, 0xFF, 0x7F };
- delta_file_.replace(delta_file_header_.size() + offset,
- bytes_to_replace,
-- kMaxVarint,
-+ reinterpret_cast<const char*>(kMaxVarint),
- sizeof(kMaxVarint));
- }
-
-@@ -112,10 +113,10 @@
- // in the delta window.
- void VCDiffDecoderTest::WriteNegativeVarintAtOffset(int offset,
- int bytes_to_replace) {
-- static const char kNegativeVarint[] = { 0x88, 0x80, 0x80, 0x80, 0x00 };
-+ static const uint8_t kNegativeVarint[] = { 0x88, 0x80, 0x80, 0x80, 0x00 };
- delta_file_.replace(delta_file_header_.size() + offset,
- bytes_to_replace,
-- kNegativeVarint,
-+ reinterpret_cast<const char*>(kNegativeVarint),
- sizeof(kNegativeVarint));
- }
-
-@@ -123,18 +124,18 @@
- // at the given offset in the delta window.
- void VCDiffDecoderTest::WriteInvalidVarintAtOffset(int offset,
- int bytes_to_replace) {
-- static const char kInvalidVarint[] = { 0x87, 0xFF, 0xFF, 0xFF, 0xFF, 0x7F };
-+ static const uint8_t kInvalidVarint[] = { 0x87, 0xFF, 0xFF, 0xFF, 0xFF, 0x7F };
- delta_file_.replace(delta_file_header_.size() + offset,
- bytes_to_replace,
-- kInvalidVarint,
-+ reinterpret_cast<const char*>(kInvalidVarint),
- sizeof(kInvalidVarint));
- }
-
- bool VCDiffDecoderTest::FuzzOneByteInDeltaFile() {
- static const struct Fuzzer {
-- char _and;
-- char _or;
-- char _xor;
-+ uint8_t _and;
-+ uint8_t _or;
-+ uint8_t _xor;
- } fuzzers[] = {
- { 0xff, 0x80, 0x00 },
- { 0xff, 0xff, 0x00 },
-@@ -162,7 +163,7 @@
- return false;
- }
-
--const char VCDiffStandardDecoderTest::kWindowHeader[] = {
-+const uint8_t VCDiffStandardDecoderTest::kWindowHeader[] = {
- VCD_SOURCE, // Win_Indicator: take source from dictionary
- FirstByteOfStringLength(kDictionary), // Source segment size
- SecondByteOfStringLength(kDictionary),
-@@ -176,7 +177,7 @@
- 0x03 // length of addresses for COPYs
- };
-
--const char VCDiffStandardDecoderTest::kWindowBody[] = {
-+const uint8_t VCDiffStandardDecoderTest::kWindowBody[] = {
- // Data for ADDs: 1st section (length 61)
- ' ', 'I', ' ', 'h', 'a', 'v', 'e', ' ', 's', 'a', 'i', 'd', ' ',
- 'i', 't', ' ', 't', 'w', 'i', 'c', 'e', ':', '\n',
-@@ -216,11 +217,13 @@
-
- VCDiffStandardDecoderTest::VCDiffStandardDecoderTest() {
- UseStandardFileHeader();
-- delta_window_header_.assign(kWindowHeader, sizeof(kWindowHeader));
-- delta_window_body_.assign(kWindowBody, sizeof(kWindowBody));
-+ delta_window_header_.assign(reinterpret_cast<const char *>(kWindowHeader),
-+ sizeof(kWindowHeader));
-+ delta_window_body_.assign(reinterpret_cast<const char *>(kWindowBody),
-+ sizeof(kWindowBody));
- }
-
--const char VCDiffInterleavedDecoderTest::kWindowHeader[] = {
-+const uint8_t VCDiffInterleavedDecoderTest::kWindowHeader[] = {
- VCD_SOURCE, // Win_Indicator: take source from dictionary
- FirstByteOfStringLength(kDictionary), // Source segment size
- SecondByteOfStringLength(kDictionary),
-@@ -234,7 +237,7 @@
- 0x00 // length of addresses for COPYs (unused)
- };
-
--const char VCDiffInterleavedDecoderTest::kWindowBody[] = {
-+const uint8_t VCDiffInterleavedDecoderTest::kWindowBody[] = {
- 0x13, // VCD_COPY mode VCD_SELF, size 0
- 0x1C, // Size of COPY (28)
- 0x00, // Address of COPY: Start of dictionary
-@@ -272,8 +275,10 @@
-
- VCDiffInterleavedDecoderTest::VCDiffInterleavedDecoderTest() {
- UseInterleavedFileHeader();
-- delta_window_header_.assign(kWindowHeader, sizeof(kWindowHeader));
-- delta_window_body_.assign(kWindowBody, sizeof(kWindowBody));
-+ delta_window_header_.assign(reinterpret_cast<const char *>(kWindowHeader),
-+ sizeof(kWindowHeader));
-+ delta_window_body_.assign(reinterpret_cast<const char *>(kWindowBody),
-+ sizeof(kWindowBody));
- }
-
- } // namespace open_vcdiff
---- a/src/vcdecoder_test.h
-+++ b/src/vcdecoder_test.h
-@@ -16,6 +16,7 @@
- #define OPEN_VCDIFF_VCDECODER_TEST_H_
-
- #include "google/vcdecoder.h"
-+#include <stdint.h> // utf8_t
- #include <string>
- #include "checksum.h"
- #include "testing.h"
-@@ -80,7 +81,7 @@
- // Assuming the length of the given string can be expressed as a VarintBE
- // of length N, this function returns the byte at position which_byte, where
- // 0 <= which_byte < N.
-- static char GetByteFromStringLength(const char* s, int which_byte);
-+ static uint8_t GetByteFromStringLength(const char* s, int which_byte);
-
- // Assuming the length of the given string can be expressed as a one-byte
- // VarintBE, this function returns that byte value.
-@@ -90,13 +91,13 @@
-
- // Assuming the length of the given string can be expressed as a two-byte
- // VarintBE, this function returns the first byte of its representation.
-- static char FirstByteOfStringLength(const char* s) {
-+ static uint8_t FirstByteOfStringLength(const char* s) {
- return GetByteFromStringLength(s, 0);
- }
-
- // Assuming the length of the given string can be expressed as a two-byte
- // VarintBE, this function returns the second byte of its representation.
-- static char SecondByteOfStringLength(const char* s) {
-+ static uint8_t SecondByteOfStringLength(const char* s) {
- return GetByteFromStringLength(s, 1);
- }
-
-@@ -124,8 +125,8 @@
- private:
- // These values should only be accessed via UseStandardFileHeader() and
- // UseInterleavedFileHeader().
-- static const char kStandardFileHeader[];
-- static const char kInterleavedFileHeader[];
-+ static const uint8_t kStandardFileHeader[];
-+ static const uint8_t kInterleavedFileHeader[];
-
- // These two counters are used by FuzzOneByteInDeltaFile() to iterate through
- // different ways to corrupt the delta file.
-@@ -141,8 +142,8 @@
- virtual ~VCDiffStandardDecoderTest() {}
-
- private:
-- static const char kWindowHeader[];
-- static const char kWindowBody[];
-+ static const uint8_t kWindowHeader[];
-+ static const uint8_t kWindowBody[];
- };
-
- class VCDiffInterleavedDecoderTest : public VCDiffDecoderTest {
-@@ -151,8 +152,8 @@
- virtual ~VCDiffInterleavedDecoderTest() {}
-
- private:
-- static const char kWindowHeader[];
-- static const char kWindowBody[];
-+ static const uint8_t kWindowHeader[];
-+ static const uint8_t kWindowBody[];
- };
-
- } // namespace open_vcdiff
diff --git a/dev-util/open-vcdiff/metadata.xml b/dev-util/open-vcdiff/metadata.xml
deleted file mode 100644
index 4d97c1a4a4ec..000000000000
--- a/dev-util/open-vcdiff/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <upstream>
- <remote-id type="google-code">open-vcdiff</remote-id>
- <remote-id type="github">google/open-vcdiff</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-util/open-vcdiff/open-vcdiff-0.8.4-r1.ebuild b/dev-util/open-vcdiff/open-vcdiff-0.8.4-r1.ebuild
deleted file mode 100644
index 18324677305e..000000000000
--- a/dev-util/open-vcdiff/open-vcdiff-0.8.4-r1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="An encoder/decoder for the VCDIFF (RFC3284) format"
-HOMEPAGE="https://github.com/google/open-vcdiff"
-SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
-
-src_configure() {
- econf --disable-static
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}