summaryrefslogtreecommitdiff
path: root/dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild')
-rw-r--r--dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild b/dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild
new file mode 100644
index 000000000000..56bd4273a95d
--- /dev/null
+++ b/dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="A license identification tool for source code"
+HOMEPAGE="http://ninka.turingmachine.org/"
+# snapshot of https://github.com/dmgerman/ninka
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ myspell-en_CA-KevinAtkinson public-domain Princeton Ispell"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sqlite test"
+
+RDEPEND="dev-perl/IO-CaptureOutput
+ dev-perl/Spreadsheet-WriteExcel
+ virtual/perl-File-Temp
+ sqlite? (
+ dev-perl/DBD-SQLite
+ dev-perl/DBI
+ )"
+
+DEPEND="virtual/perl-ExtUtils-MakeMaker
+ test? (
+ ${RDEPEND}
+ dev-perl/Test-Pod
+ dev-perl/Test-Strict
+ virtual/perl-Test-Simple
+ )"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-braces.patch
+ "${FILESDIR}"/${P}-makefile.patch
+)
+
+src_compile() {
+ perl-module_src_compile
+ emake -C comments CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ perl-module_src_install
+ use sqlite || rm "${ED}"/usr/bin/ninka-sqlite || die
+ dobin comments/comments
+ doman comments/comments.1
+ dodoc BUGS.org
+}