summaryrefslogtreecommitdiff
path: root/dev-util/mingw64-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-util/mingw64-runtime
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-util/mingw64-runtime')
-rw-r--r--dev-util/mingw64-runtime/Manifest3
-rw-r--r--dev-util/mingw64-runtime/metadata.xml1
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-6.0.0-r2.ebuild113
3 files changed, 116 insertions, 1 deletions
diff --git a/dev-util/mingw64-runtime/Manifest b/dev-util/mingw64-runtime/Manifest
index a981f43d31f3..1d06b93d85aa 100644
--- a/dev-util/mingw64-runtime/Manifest
+++ b/dev-util/mingw64-runtime/Manifest
@@ -2,4 +2,5 @@ DIST mingw-w64-v5.0.4.tar.bz2 9163093 BLAKE2B fd039995c73690c12ddf1612d42edefbb5
DIST mingw-w64-v6.0.0.tar.bz2 9045653 BLAKE2B 8a54dca2d06c92ab968a93240996d07ab3b1ed4652555a48b7581c477856d5784ed192c578d78186e171e400bd18b4de3c6cafbdd96109367ad13c37792015c1 SHA512 e3d3663e0cb33a16f90b1a33e81b5a30d26f7e34270b14e865c10068f2a2d32da9ef8cbbb0c3fed9c71429ae11c82152ff3b87d81558929b2a4993dc99cfc11e
EBUILD mingw64-runtime-5.0.4.ebuild 2548 BLAKE2B 82805af12130881e40369c5c2074bd622f4ce19e3d1ca1b845d6f03bfe84c271b22ee55d1ba639827d67506262a05f917509df2d632b34cca141d62a02487539 SHA512 bc4fdf9844d0b09ac4045cd51529b14ecf9fe8bb4f2fa428d141bdcb6352a0b1912d471ac133b768dcd26c65c05d345594123fade22f525b8fd803b234b9250d
EBUILD mingw64-runtime-6.0.0-r1.ebuild 2862 BLAKE2B b10758329649069509ca617a9b1159f480eb1b84c89bf9130004b2d1e089dcdb02ac6a896b376dd7486c6fc86c12468162f089377ba2fc5390549476957ef83c SHA512 4dc7a111aab0b5a01cb1559efe7ca4126b32f77e88852ff2940cfe23fb78ade8561653c3f9d08a1e0530e875227ab50f51d820c887737454491306fc29b12ca5
-MISC metadata.xml 563 BLAKE2B 84e56e99482d2f7bb1e1095d84915b42190ba74fe7242ffdce548c4249a40be17018a29911d32b9b09df8fc5e04d912dcfe6f473e5eb2478f55d317808b24f4b SHA512 27dca35a3b2d5444b712802c3099c595d9b9fda21f29b6b709222e5bb0aad78f353d0170500eb3b632b254935d35cf43fc43d4ecb61722b711799ca4d28211bd
+EBUILD mingw64-runtime-6.0.0-r2.ebuild 2903 BLAKE2B a9724a30a903a58e48916030c66e43d63c442bc6d75e955e692884804295bb4743feb36ffb906a9709026d57004c8a91677f52497558095933a10c965314431a SHA512 ef1747e6243e5f104d69452e56b16cc2e8c88dce1522acb5d07d6f063b67c8150eed77adb178701e78889b81f903376418595227bacd0d946eed950be89be6d8
+MISC metadata.xml 643 BLAKE2B a66741716a2729da314650e4435c616a0a3912cedcc142f23ce74b23c59e21b8a456697a7d38880c1b7d876909ba4b3617a0c72c9f054fcbcbe68841d76c5903 SHA512 fd9528a194bcda889d719ba7f4759414b86cc0d75d9790a9478c46e2abf62b01355e4e01b8e05b7accda0ff0dab94607182671f367cf600e47443b0d4a0bcd53
diff --git a/dev-util/mingw64-runtime/metadata.xml b/dev-util/mingw64-runtime/metadata.xml
index 1b348ca856b1..df0beeaf2e90 100644
--- a/dev-util/mingw64-runtime/metadata.xml
+++ b/dev-util/mingw64-runtime/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name="idl">Install idl files.</flag>
<flag name="libraries">Build extra libraries: mangle, pseh, winpthreads.</flag>
+ <flag name="secure-api">Expose secure API (*_s function) by default.</flag>
<flag name="tools">Build extra tools: gendef, genidl.</flag>
</use>
<upstream>
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-6.0.0-r2.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-6.0.0-r2.ebuild
new file mode 100644
index 000000000000..9dc20f91b732
--- /dev/null
+++ b/dev-util/mingw64-runtime/mingw64-runtime-6.0.0-r2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+inherit autotools flag-o-matic eutils
+
+DESCRIPTION="Free Win64 runtime and import library definitions"
+HOMEPAGE="http://mingw-w64.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# USE=libraries needs working stage2 compiler: bug #665512
+IUSE="headers-only idl libraries +secure-api tools"
+RESTRICT="strip"
+
+S="${WORKDIR}/mingw-w64-v${PV}"
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+just_headers() {
+ use headers-only
+}
+alt_prefix() {
+ is_crosscompile && echo /usr/${CTARGET}
+}
+crt_with() {
+ just_headers && echo --without-$1 || echo --with-$1
+}
+crt_use_enable() {
+ just_headers && echo --without-$2 || use_enable "$@"
+}
+crt_use_with() {
+ just_headers && echo --without-$2 || use_with "$@"
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration"
+ fi
+}
+
+src_configure() {
+ CHOST=${CTARGET} strip-unsupported-flags
+ # Normally mingw-64 does not use dynamic linker.
+ # But at configure time it uses $LDFLAGS.
+ # When default -Wl,--hash-style=gnu is passed
+ # __CTORS_LIST__ / __DTORS_LIST__ is mis-detected
+ # for target ld and binaries crash at shutdown.
+ filter-ldflags '-Wl,--hash-style=*'
+
+ if ! just_headers; then
+ mkdir "${WORKDIR}/headers"
+ pushd "${WORKDIR}/headers" > /dev/null
+ CHOST=${CTARGET} "${S}/configure" \
+ --prefix="${T}/tmproot" \
+ --with-headers \
+ --without-crt \
+ || die
+ popd > /dev/null
+ append-cppflags "-I${T}/tmproot/include"
+ fi
+
+ # By default configure tries to set --sysroot=${prefix}. We disable
+ # this behaviour with --with-sysroot=no to use gcc's sysroot default.
+ # That way we can cross-build mingw64-runtime with cross-emerge.
+ CHOST=${CTARGET} econf \
+ --with-sysroot=no \
+ --prefix="${EPREFIX}"$(alt_prefix)/usr \
+ --with-headers \
+ --enable-sdk \
+ $(crt_with crt) \
+ $(crt_use_enable idl idl) \
+ $(crt_use_with libraries libraries) \
+ $(crt_use_with tools tools) \
+ $(use_enable secure-api) \
+ $(
+ $(tc-getCPP ${CTARGET}) ${CPPFLAGS} -dM - < /dev/null | grep -q __MINGW64__ \
+ && echo --disable-lib32 --enable-lib64 \
+ || echo --enable-lib32 --disable-lib64
+ )
+}
+
+src_compile() {
+ if ! just_headers; then
+ emake -C "${WORKDIR}/headers" install
+ fi
+ default
+}
+
+src_install() {
+ default
+
+ if is_crosscompile ; then
+ # gcc is configured to look at specific hard-coded paths for mingw #419601
+ dosym usr /usr/${CTARGET}/mingw
+ dosym usr /usr/${CTARGET}/${CTARGET}
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+
+ rm -rf "${ED}/usr/share"
+}