summaryrefslogtreecommitdiff
path: root/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-16 19:46:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-16 19:46:11 +0100
commit1fd4e372381e1318aae1b7d3338c04156e5da974 (patch)
treed480b13516da01073c455f4a216a5645d4114190 /dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
parent29607d91fb1bf1c4456a0b90601ee172ea769283 (diff)
gentoo auto-resync : 16:07:2022 - 19:46:10
Diffstat (limited to 'dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild')
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
index 004d6be49356..d25b7c5a8cd2 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
@@ -61,8 +61,10 @@ src_configure() {
MW_LDFLAGS=${LDFLAGS} # keep non-stripped for gendef not respecting it
# likely cross-compiling from here, update toolchain variables
- ${MW_CROSS} && [[ ! -v MINGW_BYPASS ]] &&
+ if ${MW_CROSS} && [[ ! -v MINGW_BYPASS ]]; then
unset AR AS CC CPP CXX LD NM OBJCOPY OBJDUMP RANLIB RC STRIP
+ filter-flags '-fuse-ld=*'
+ fi
local CHOST=${CTARGET}
strip-unsupported-flags