summaryrefslogtreecommitdiff
path: root/dev-util/meson/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-util/meson/files
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-util/meson/files')
-rw-r--r--dev-util/meson/files/meson-tests-rust-add-libm.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/meson/files/meson-tests-rust-add-libm.patch b/dev-util/meson/files/meson-tests-rust-add-libm.patch
new file mode 100644
index 000000000000..45803976bb9b
--- /dev/null
+++ b/dev-util/meson/files/meson-tests-rust-add-libm.patch
@@ -0,0 +1,22 @@
+From 7ad54cce49ce22b063e0cd56edb4b7f722dc5e8e Mon Sep 17 00:00:00 2001
+From: Dominique Leuenberger <dimstar@opensuse.org>
+Date: Wed, 29 Sep 2021 14:20:53 +0200
+Subject: [PATCH] tests/rust: add libm to fix build with rust 1.55
+
+Fixes #9309
+---
+ test cases/rust/5 polyglot static/meson.build | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/test cases/rust/5 polyglot static/meson.build b/test cases/rust/5 polyglot static/meson.build
+index de2e61bcbc3..a6e9550b6e2 100644
+--- a/test cases/rust/5 polyglot static/meson.build
++++ b/test cases/rust/5 polyglot static/meson.build
+@@ -2,6 +2,7 @@ project('static rust and c polyglot executable', 'c', 'rust')
+
+ deps = [
+ meson.get_compiler('c').find_library('dl', required: false),
++ meson.get_compiler('c').find_library('m', required: false),
+ dependency('threads'),
+ ]
+