summaryrefslogtreecommitdiff
path: root/dev-util/mdds/mdds-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-util/mdds/mdds-2.0.3.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-util/mdds/mdds-2.0.3.ebuild')
-rw-r--r--dev-util/mdds/mdds-2.0.3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/mdds/mdds-2.0.3.ebuild b/dev-util/mdds/mdds-2.0.3.ebuild
new file mode 100644
index 000000000000..6599638fac76
--- /dev/null
+++ b/dev-util/mdds/mdds-2.0.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+ inherit git-r3
+else
+ SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
+fi
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="https://gitlab.com/mdds/mdds"
+
+LICENSE="MIT"
+SLOT="1/2.0" # Check API version on version bumps!
+IUSE="doc openmp valgrind test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ )
+ valgrind? ( dev-util/valgrind )
+"
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.5.0-buildsystem.patch" )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable openmp)
+ $(use_enable valgrind memory_tests)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ tc-export CXX
+ default
+}