summaryrefslogtreecommitdiff
path: root/dev-util/mdds/mdds-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-util/mdds/mdds-1.6.0.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-util/mdds/mdds-1.6.0.ebuild')
-rw-r--r--dev-util/mdds/mdds-1.6.0.ebuild26
1 files changed, 21 insertions, 5 deletions
diff --git a/dev-util/mdds/mdds-1.6.0.ebuild b/dev-util/mdds/mdds-1.6.0.ebuild
index dce25723cffd..9364d50feb9a 100644
--- a/dev-util/mdds/mdds-1.6.0.ebuild
+++ b/dev-util/mdds/mdds-1.6.0.ebuild
@@ -8,7 +8,7 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
else
SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
fi
inherit autotools toolchain-funcs
@@ -16,8 +16,8 @@ DESCRIPTION="A collection of multi-dimensional data structure and indexing algor
HOMEPAGE="https://gitlab.com/mdds/mdds"
LICENSE="MIT"
-SLOT="1/1.5"
-IUSE="doc valgrind test"
+SLOT="1/1.5" # Check API version on version bumps!
+IUSE="doc openmp valgrind test"
RESTRICT="!test? ( test )"
BDEPEND="
@@ -30,11 +30,21 @@ BDEPEND="
DEPEND="dev-libs/boost:="
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-1.5.0-buildsystem.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.0-buildsystem.patch"
+ "${FILESDIR}/${P}-bashism.patch" # bug 723094
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
src_prepare() {
default
-
eautoreconf
}
@@ -43,6 +53,12 @@ src_configure() {
$(use_enable doc docs)
$(use_enable valgrind memory_tests)
)
+ if use openmp && tc-has-openmp; then
+ myeconfargs+=( --enable-openmp )
+ else
+ myeconfargs+=( --disable-openmp )
+ fi
+
econf "${myeconfargs[@]}"
}