summaryrefslogtreecommitdiff
path: root/dev-util/mage/mage-1.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-util/mage/mage-1.11.0.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-util/mage/mage-1.11.0.ebuild')
-rw-r--r--dev-util/mage/mage-1.11.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-util/mage/mage-1.11.0.ebuild b/dev-util/mage/mage-1.11.0.ebuild
new file mode 100644
index 000000000000..b589b5b0780b
--- /dev/null
+++ b/dev-util/mage/mage-1.11.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="make/rake like tool using go"
+HOMEPAGE="https://magefile.org"
+SRC_URI="https://github.com/magefile/mage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ GOBIN="${S}/bin" go run bootstrap.go || die "build failed"
+}
+
+src_install() {
+dobin bin/mage
+}