summaryrefslogtreecommitdiff
path: root/dev-util/lxqt-build-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-util/lxqt-build-tools
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-util/lxqt-build-tools')
-rw-r--r--dev-util/lxqt-build-tools/Manifest2
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
index 045c601e294d..f6fbea4619b9 100644
--- a/dev-util/lxqt-build-tools/Manifest
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -1,3 +1,5 @@
+DIST lxqt-build-tools-0.10.0.tar.xz 25312 BLAKE2B 7ba08ee181353454264685f6ec7407cd4858acd55674213a5f2bab123b400e6caae0eb5e803ca4d0dc30b19ca069c0659c4531ac64ee017fcd619560e09195fd SHA512 ee7282344c6fbf09d85f845c60075b6c343ce6b6f8c233c7d664faff3b570e2836192aa2233b951242b66d86254971011d4d0bc225811344829fdc5bc83b0e5f
DIST lxqt-build-tools-0.9.0.tar.xz 25296 BLAKE2B 9686a445c75a700a38150b4493f6c019ba0782e219b3482f67c6a324f35ffe252fddc614daefbd8616ee16ef8bc331c7e4302ddf2df870d1c3696a80cfb585a8 SHA512 9a464393ea6d871c5856ebf5b8fa3d31a89c6419ac084e7146aed675f2b20a139bb3eedde017d6ca03167ee6e30a37a62239ab4e8b76f5b6db244d26ab164892
+EBUILD lxqt-build-tools-0.10.0.ebuild 539 BLAKE2B a2ca92eafbf48e8b8bd601c7d8492a7b77e002e2128bb155f1f176b4a74fd6c9f4acaaa2cc892aa27edb20a98cf362c50f41046489e5514cad10c1ad4366fb51 SHA512 4e7aa2c53e5ff9cfd507a645d595e8bc176fb7ba2128c969b2ca229b83646edbd5849a34b499b60d6f69f6791fcf954d1716385ae5ebbdf695092885c2dc33b3
EBUILD lxqt-build-tools-0.9.0.ebuild 528 BLAKE2B 7b1f78a49c2125264ef5d4a539359f60dbd733e09f238e0bb26bb2c74b88d7bc84c4ac55bed02a6fb6c65071cd62ea8223c2a49f58962a24e32bfd4956b5347b SHA512 78fe92caaf494d6699279d55b144221cf9e141b15a8eddc6ca6d1f07467f8e9f8b5e3ecbec187383f639c635f137c6f2ba5ca5f725d1b3f1af8d4295a925e620
MISC metadata.xml 323 BLAKE2B 23d737cdebbafa977534a82a3244d697f8d3b55b16715d344ec46da7c71eb68d480e3a4196944e800400c94c900f240f92ffffc092c68aceeeb95c8cdead9a87 SHA512 403f0f0d13ce990a814e653032166c8cab4d3ea8924aec77f46050760d94e26afb42cb1d793ca4eda3a04a402f3817646cc876c35b506d1bff80bc03a020f0f6
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0.ebuild
new file mode 100644
index 000000000000..60e7f2c36aad
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=dev-qt/qtcore-5.15:5
+"
+RDEPEND="${DEPEND}"