summaryrefslogtreecommitdiff
path: root/dev-util/lxqt-build-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-util/lxqt-build-tools
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-util/lxqt-build-tools')
-rw-r--r--dev-util/lxqt-build-tools/Manifest2
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.8.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
index 951af615275a..86254de90c6f 100644
--- a/dev-util/lxqt-build-tools/Manifest
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-build-tools-0.7.0.tar.xz 24436 BLAKE2B b3bc9a62c530e682cff5412400d0fb14958d6aabddaef8c76b0073b01d356a9e7b227436428a3810f6b442dd77e57f4efb080a4902261679ad2c7898cf3098cb SHA512 7b6fd30e6ae8355ae36be55f8f7d47d78f507c11ebd9cbdd1d2ce5f14db68b845ad0bb8ca05fa1122bfd4c41f6dc792dff5100dcb8e61167517c3704527c7cde
+DIST lxqt-build-tools-0.8.0.tar.xz 25340 BLAKE2B c83524a5688cf38521406e50ad08e93b20d246c0fe779929905cd5aaff67ece6b7dae483d1d4f21657b913ab2ffc7ec821a3025ac6fe3585028146d1746f7565 SHA512 7c235df623ae8c88fa551f38bf24d0621958ce3586296a798b50bbce87084cb624298f4e5aaaa40d3244afae17b7fa373d2b8b6084377f9d7a355fc4bfcbb531
EBUILD lxqt-build-tools-0.7.0.ebuild 521 BLAKE2B eb7b9f78ca0768842c4bf5cab81eb36e03a83f12212d87544afdbe2c3281478449c1abf0f464ad1243fb9362302ff6f8650c0720d9ee8448b40b996e30fa39a7 SHA512 f09c1e84e0f31a3732596bc641ebd165f2dcb0785be533c31c8db54b49ef8a9ab564b3c0f14e0c34c3a33308997cab10c814fcd478fef521f4a2157acc51f753
+EBUILD lxqt-build-tools-0.8.0.ebuild 523 BLAKE2B 4ed1b96274339d24add91d6de7e2b6a07a57de60281abb6ef79a06e6f416dbc0aa17522d0ab300633114c6c9c968ee11fbd14179ad4e6469b7b0d1b44c3f30a8 SHA512 40e6ac6134676eec50e89eab19fe24eea7e085caadcc866d8091254530045ac2f9cc6079f7cf2e6126892ea8cc5189fafd1d54291364bd244fe696fe227a1fce
MISC metadata.xml 322 BLAKE2B 8b119aeafbe57841b2e072a7a009dd20383a752d6cce052c5b2e6c98c2341baad6e74fbb8798ffbf5c17719a37ff4d25efda922fcc32bf851b82e520af69777b SHA512 ffd6f030759c5c9e6f2aa42550a0de265550a03872c7b11c12ac4429a7dd1c3cbdb7cb470238273a313e9fcddbc5072b7dc4909811c4ab7609c0acc2e385a948
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.8.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.8.0.ebuild
new file mode 100644
index 000000000000..ce1e2b0aad19
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.8.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ dev-qt/qtcore:5
+"
+RDEPEND="${DEPEND}"