summaryrefslogtreecommitdiff
path: root/dev-util/lxqt-build-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-util/lxqt-build-tools
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-util/lxqt-build-tools')
-rw-r--r--dev-util/lxqt-build-tools/Manifest2
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
index d29527394589..d8a7242c3f24 100644
--- a/dev-util/lxqt-build-tools/Manifest
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-build-tools-0.5.0.tar.xz 23392 BLAKE2B 1f28ae093af772ed2b6f75a7933b76a2c608171bf15e0c8483477d7f3b702dec79f41af70bb38863c3b17ff9d52a8f2acabd4ed2347bb7f421d2074b8767e96c SHA512 6802f3d5e3d622b136cf312ad929353aac1f42355c00ac9e3fb7a9d46c63dba1f87a0a4fd11185289c4e7222d5b0d30b8829dacd38c88de45901ff0559639e90
+DIST lxqt-build-tools-0.6.0.tar.xz 22520 BLAKE2B 99e8032e111f776708d0a84e65db6534f517e75803d2cf747618889dccc46e9d55caa0ba3c89c88d56143a69ced015df9f1eae68a34c7ea050c6f97aedcf0f33 SHA512 f95c47d40f26defa8bc4e13a0449428945c282cb5e2201610e9529bfd5154a438ee9dcc4f556bd76efe13b97533bbed2f49ab5c100225907781093094a692227
EBUILD lxqt-build-tools-0.5.0.ebuild 503 BLAKE2B 79a8b9b8f017d64574c9b27ea37bc5d996bc7a3e9bfffce322fe63bc85690e013664dbeaf79ff2371b060f88c1bf2bb84ca2597fbf93b56b03daed8891453db2 SHA512 d95996271fa9f93b4efe8ffb16498c5431d8d83909ff271fe5783c393fe3506c89bceb997aae0f912ad325d84dcd34f53ff36c569b66dbb22ed8d7e46fc4cc3b
+EBUILD lxqt-build-tools-0.6.0.ebuild 512 BLAKE2B e6294f672a7e6b3eda41e2eceb4dfbf711561d7653021772237715a627531a6a5ae215e4f95164ac3be0f3bdf8c9698c553320ecda13ee2b1da81120829e266e SHA512 523b7f62ee39adb6548788b404914365e5c2032671040bb203d1e3296f35c17d59e976c80037ee61aacb6fb64cb34f1530f3973de16af27fb107171f0d16a0e0
MISC metadata.xml 322 BLAKE2B 8b119aeafbe57841b2e072a7a009dd20383a752d6cce052c5b2e6c98c2341baad6e74fbb8798ffbf5c17719a37ff4d25efda922fcc32bf851b82e520af69777b SHA512 ffd6f030759c5c9e6f2aa42550a0de265550a03872c7b11c12ac4429a7dd1c3cbdb7cb470238273a313e9fcddbc5072b7dc4909811c4ab7609c0acc2e385a948
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild
new file mode 100644
index 000000000000..7cd05eadac92
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="LXQt Build tools"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ dev-qt/qtcore:5
+"
+RDEPEND="${DEPEND}"