summaryrefslogtreecommitdiff
path: root/dev-util/lxqt-build-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-15 00:09:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-15 00:09:17 +0100
commit6a7029e0f7370d4d5dfe9e31cc2719a870482392 (patch)
tree28c6c747114eaedfd2db81f86ac2ff3d7d13111e /dev-util/lxqt-build-tools
parent5e41a38157bb40e8513e8e34426e85faba672fe7 (diff)
gentoo auto-resync : 15:06:2024 - 00:09:17
Diffstat (limited to 'dev-util/lxqt-build-tools')
-rw-r--r--dev-util/lxqt-build-tools/Manifest2
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-2.0.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
index 1174c6fd2923..70f1fe78ca77 100644
--- a/dev-util/lxqt-build-tools/Manifest
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-build-tools-0.13.0.tar.xz 25480 BLAKE2B aebbcb55851b0acc00bf4d34e3846e12a3d503e4f7238ba57d7d6b3df44ccd8e6dbe5fc1986ed722dfd4384ad17f22be14fa0c6270b3ed385ae7cd4ff5711e3e SHA512 ffb300159d6bbbdbe9d43d261a5028342f24057c943cf8dab5093d53b72bf5700de8f545914d454993e949d64aba77e3d01cbe68e8a4b4f6ca9f9f9693de3e0b
+DIST lxqt-build-tools-2.0.0.tar.xz 26072 BLAKE2B a549dbe4b2e93d33d0238efe4e419c867db49e626436c243c8080cd4d925212edfb531bb2d9b661d675b7c9b9fec076a4a6f2d144f414ebc3babacada75877e3 SHA512 4fe92af82d55bda8fc1b6dc44998ed64b031e33a5c19e9206c1822375b8aa8abbf5f5b94d3c5ebe6d5d318f8821664ee308064b7adb9081e08047a4456cc6a66
EBUILD lxqt-build-tools-0.13.0.ebuild 543 BLAKE2B 4214b2adad5fe03ce742b99c688a549992857d425d23b2a55fee0c72596676445d347759daaceede0e84c53dc6c462483d855c87841e67cb0da3455d6723d664 SHA512 d2c685893bd39c16218dfc0822bf2e552dca529c81f85d9cccb1ebd16c0e45a7207c23fb541348ef84c8beef05c16ed115bcc94e9473392c5324824cd432ae0e
+EBUILD lxqt-build-tools-2.0.0.ebuild 1351 BLAKE2B 334b94f032fd67b2e6d6c7ccb0b0637adb84b43bfc1fe277a7d234762db123e32023c598f3c4f90feeb05cbf8c86cadd4a5f42d4f7435770e23e817e6fcab97e SHA512 beaf03706f9cc5c6f158d8125243e2bd47a79151efacc011a2e692c6787a016e172f8fab87b5ded7fa13b2bba319c032af2ab7abafb6b091ed1895f8e5c46fba
MISC metadata.xml 323 BLAKE2B 23d737cdebbafa977534a82a3244d697f8d3b55b16715d344ec46da7c71eb68d480e3a4196944e800400c94c900f240f92ffffc092c68aceeeb95c8cdead9a87 SHA512 403f0f0d13ce990a814e653032166c8cab4d3ea8924aec77f46050760d94e26afb42cb1d793ca4eda3a04a402f3817646cc876c35b506d1bff80bc03a020f0f6
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-2.0.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-2.0.0.ebuild
new file mode 100644
index 000000000000..52e9e5be77b7
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-2.0.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=dev-qt/qtbase-6.6:6
+"
+RDEPEND="${DEPEND}
+ !<=app-arch/lxqt-archiver-1
+ !<=app-misc/qtxdg-tools-4
+ !<=dev-libs/libqtxdg-4
+ !<=gui-libs/xdg-desktop-portal-lxqt-1
+ !<=lxqt-base/liblxqt-2
+ !<=lxqt-base/libsysstat-1
+ !<=lxqt-base/lxqt-about-2
+ !<=lxqt-base/lxqt-admin-2
+ !<=lxqt-base/lxqt-config-2
+ !<=lxqt-base/lxqt-globalkeys-2
+ !<=lxqt-base/lxqt-menu-data-2
+ !<=lxqt-base/lxqt-meta-2
+ !<=lxqt-base/lxqt-notificationd-2
+ !<=lxqt-base/lxqt-openssh-askpass-2
+ !<=lxqt-base/lxqt-panel-2
+ !<=lxqt-base/lxqt-policykit-2
+ !<=lxqt-base/lxqt-powermanagement-2
+ !<=lxqt-base/lxqt-qtplugin-2
+ !<=lxqt-base/lxqt-runner-2
+ !<=lxqt-base/lxqt-session-2
+ !<=lxqt-base/lxqt-sudo-2
+ !<=media-gfx/lximage-qt-2
+ !<=x11-libs/libfm-qt-2
+ !<=x11-libs/qtermwidget-2
+ !x11-misc/obconf-qt
+ !<=x11-misc/pcmanfm-qt-2
+ !<=x11-misc/qps-2.9
+ !<=x11-misc/screengrab-2.8
+ !<=x11-terms/qterminal-2
+ !<=x11-themes/lxqt-themes-2
+"