summaryrefslogtreecommitdiff
path: root/dev-util/lxqt-build-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-util/lxqt-build-tools
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-util/lxqt-build-tools')
-rw-r--r--dev-util/lxqt-build-tools/Manifest2
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.9.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
index 4a243be48efc..848a6ec2d487 100644
--- a/dev-util/lxqt-build-tools/Manifest
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-build-tools-0.8.0.tar.xz 25340 BLAKE2B c83524a5688cf38521406e50ad08e93b20d246c0fe779929905cd5aaff67ece6b7dae483d1d4f21657b913ab2ffc7ec821a3025ac6fe3585028146d1746f7565 SHA512 7c235df623ae8c88fa551f38bf24d0621958ce3586296a798b50bbce87084cb624298f4e5aaaa40d3244afae17b7fa373d2b8b6084377f9d7a355fc4bfcbb531
+DIST lxqt-build-tools-0.9.0.tar.xz 25296 BLAKE2B 9686a445c75a700a38150b4493f6c019ba0782e219b3482f67c6a324f35ffe252fddc614daefbd8616ee16ef8bc331c7e4302ddf2df870d1c3696a80cfb585a8 SHA512 9a464393ea6d871c5856ebf5b8fa3d31a89c6419ac084e7146aed675f2b20a139bb3eedde017d6ca03167ee6e30a37a62239ab4e8b76f5b6db244d26ab164892
EBUILD lxqt-build-tools-0.8.0.ebuild 521 BLAKE2B 29c94964ecb76b8264a56fbc2c0aec8c0159ccdfb8485bfba914fb968f2c063183f016c0772b182722e543bf0aca4a3b8c999d12e725f4ccf4af70d52b6a03e7 SHA512 782dc789d83ae028ac55a80cc0a8d7686f1912e443a2be13204fc22151a74587ba6dd3f2caaeff8f74f42f76254d92cf72f3c66a4411a6b0763c94e7e4e7bdaa
+EBUILD lxqt-build-tools-0.9.0.ebuild 523 BLAKE2B 717962fc63c9334e4a027c04a21e1db179d4e744e809c027f2d08fa536de79778da0512181e73b22c11ebc18ac0579074b5c3214f554afd3da150ad0bd0cd4d6 SHA512 fe2454b036d71fe1ed0ec26054fba1dd38587a81fe0aeb330a7b7c641d6d0ddcd71c2d7af1b60aae3b4eaf1a2a01b163792a54d6f3b1e635645241cdd8c50fd0
MISC metadata.xml 322 BLAKE2B 8b119aeafbe57841b2e072a7a009dd20383a752d6cce052c5b2e6c98c2341baad6e74fbb8798ffbf5c17719a37ff4d25efda922fcc32bf851b82e520af69777b SHA512 ffd6f030759c5c9e6f2aa42550a0de265550a03872c7b11c12ac4429a7dd1c3cbdb7cb470238273a313e9fcddbc5072b7dc4909811c4ab7609c0acc2e385a948
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.9.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.9.0.ebuild
new file mode 100644
index 000000000000..ef30bb8aa5ab
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.9.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ dev-qt/qtcore:5
+"
+RDEPEND="${DEPEND}"