summaryrefslogtreecommitdiff
path: root/dev-util/lxqt-build-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-08 03:03:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-08 03:03:28 +0000
commit2cd9ff612e84f0c1ef63c9e9e13be53fe576cc2b (patch)
tree6e975e18646dac9f4b55fab980271a027428cc4d /dev-util/lxqt-build-tools
parentabe17cf152eeb7571da8db4b25a30465644a41ba (diff)
gentoo auto-resync : 08:11:2024 - 03:03:27
Diffstat (limited to 'dev-util/lxqt-build-tools')
-rw-r--r--dev-util/lxqt-build-tools/Manifest2
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-2.1.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
index 3d10541dfbe2..3ce23dcea169 100644
--- a/dev-util/lxqt-build-tools/Manifest
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -1,5 +1,7 @@
DIST lxqt-build-tools-0.13.0.tar.xz 25480 BLAKE2B aebbcb55851b0acc00bf4d34e3846e12a3d503e4f7238ba57d7d6b3df44ccd8e6dbe5fc1986ed722dfd4384ad17f22be14fa0c6270b3ed385ae7cd4ff5711e3e SHA512 ffb300159d6bbbdbe9d43d261a5028342f24057c943cf8dab5093d53b72bf5700de8f545914d454993e949d64aba77e3d01cbe68e8a4b4f6ca9f9f9693de3e0b
DIST lxqt-build-tools-2.0.0.tar.xz 26072 BLAKE2B a549dbe4b2e93d33d0238efe4e419c867db49e626436c243c8080cd4d925212edfb531bb2d9b661d675b7c9b9fec076a4a6f2d144f414ebc3babacada75877e3 SHA512 4fe92af82d55bda8fc1b6dc44998ed64b031e33a5c19e9206c1822375b8aa8abbf5f5b94d3c5ebe6d5d318f8821664ee308064b7adb9081e08047a4456cc6a66
+DIST lxqt-build-tools-2.1.0.tar.xz 26088 BLAKE2B c1b1dfe17113354d89c4d0c70e196f9863ce6d5e6fe1385ee369e233abd9affcee269bb9f05aacca865a1f9eb73ce3dde08926ba484e3955e4967e661b59deb9 SHA512 d5c11474125e7285e28d5d148347118d9e7110bbb93c82695c08c7231d2dcc3bc3851076795af64d5d800a2ec39a16a2533e7565c579ec01994bae4f20e3c34e
EBUILD lxqt-build-tools-0.13.0.ebuild 543 BLAKE2B 4214b2adad5fe03ce742b99c688a549992857d425d23b2a55fee0c72596676445d347759daaceede0e84c53dc6c462483d855c87841e67cb0da3455d6723d664 SHA512 d2c685893bd39c16218dfc0822bf2e552dca529c81f85d9cccb1ebd16c0e45a7207c23fb541348ef84c8beef05c16ed115bcc94e9473392c5324824cd432ae0e
EBUILD lxqt-build-tools-2.0.0-r1.ebuild 1415 BLAKE2B 080050544644964a48dc92d246fa29fc76db11e5025287bfadde0aa11a50bb768eb95d9bd14a9aeecca37e0bdfb0e7024be2965ef9408b1667bd6345a961d952 SHA512 59795ab82b8a05aa077e8bd40955eb794d3f7db07dc72a8b5d9316130093ac6f69090e21a3b1402855bf45af07602c2ff329bab251a01db78212192ea76aaa2b
+EBUILD lxqt-build-tools-2.1.0.ebuild 1426 BLAKE2B 8e80ac71fd5170656642de83004f640efccbf248f382aff8ed37731bc624b496dd4d827330d282b9a2ea71ed603678742f2a948bef80abbaea2e117793b322e3 SHA512 458dbf3481a08226081a93a864a7d615f0b327474be2abaa7e497817c7dacb7c59e3356b3fa01382bf33f43b0bf45c27b08ea4720909a27ea53f408868ce5b5e
MISC metadata.xml 323 BLAKE2B 23d737cdebbafa977534a82a3244d697f8d3b55b16715d344ec46da7c71eb68d480e3a4196944e800400c94c900f240f92ffffc092c68aceeeb95c8cdead9a87 SHA512 403f0f0d13ce990a814e653032166c8cab4d3ea8924aec77f46050760d94e26afb42cb1d793ca4eda3a04a402f3817646cc876c35b506d1bff80bc03a020f0f6
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-2.1.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-2.1.0.ebuild
new file mode 100644
index 000000000000..88e46f3be1c4
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-2.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=dev-qt/qtbase-6.6:6
+"
+RDEPEND="${DEPEND}
+ !<=app-arch/lxqt-archiver-1
+ !<=app-misc/qtxdg-tools-4
+ !<=dev-libs/libqtxdg-4
+ !<=gui-libs/xdg-desktop-portal-lxqt-1
+ !<=lxqt-base/liblxqt-2
+ !<=lxqt-base/libsysstat-1
+ !<=lxqt-base/lxqt-about-2
+ !<=lxqt-base/lxqt-admin-2
+ !<=lxqt-base/lxqt-config-2
+ !<=lxqt-base/lxqt-globalkeys-2
+ !<=lxqt-base/lxqt-menu-data-2
+ !<=lxqt-base/lxqt-meta-2
+ !<=lxqt-base/lxqt-notificationd-2
+ !<=lxqt-base/lxqt-openssh-askpass-2
+ !<=lxqt-base/lxqt-panel-2
+ !<=lxqt-base/lxqt-policykit-2
+ !<=lxqt-base/lxqt-powermanagement-2
+ !<=lxqt-base/lxqt-qtplugin-2
+ !<=lxqt-base/lxqt-runner-2
+ !<=lxqt-base/lxqt-session-2
+ !<=lxqt-base/lxqt-sudo-2
+ !<=media-gfx/lximage-qt-2
+ !<=media-sound/pavucontrol-qt-2
+ !<=x11-libs/libfm-qt-2
+ !<=x11-libs/qtermwidget-2
+ !<=x11-misc/obconf-qt-0.16.4
+ !<=x11-misc/pcmanfm-qt-2
+ !<=x11-misc/qps-2.9
+ !<=x11-misc/screengrab-2.8
+ !<=x11-terms/qterminal-2
+ !<=x11-themes/lxqt-themes-2
+"