summaryrefslogtreecommitdiff
path: root/dev-util/lldb/lldb-11.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-util/lldb/lldb-11.0.0.9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-util/lldb/lldb-11.0.0.9999.ebuild')
-rw-r--r--dev-util/lldb/lldb-11.0.0.9999.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-util/lldb/lldb-11.0.0.9999.ebuild b/dev-util/lldb/lldb-11.0.0.9999.ebuild
index a5b3aee8c3df..f16add65dbfc 100644
--- a/dev-util/lldb/lldb-11.0.0.9999.ebuild
+++ b/dev-util/lldb/lldb-11.0.0.9999.ebuild
@@ -34,6 +34,7 @@ RDEPEND="
!<sys-devel/llvm-4.0"
DEPEND="${RDEPEND}"
BDEPEND="
+ >=dev-util/cmake-3.16
python? ( >=dev-lang/swig-3.0.11 )
test? (
$(python_gen_cond_dep "
@@ -68,6 +69,8 @@ src_configure() {
# ncurses with complete library set (including autodetection
# of -ltinfo)
-DCURSES_NEED_NCURSES=ON
+
+ -DPython3_EXECUTABLE="${PYTHON}"
)
use test && mycmakeargs+=(
-DLLVM_BUILD_TESTS=$(usex test)