summaryrefslogtreecommitdiff
path: root/dev-util/libtree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-util/libtree
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-util/libtree')
-rw-r--r--dev-util/libtree/Manifest2
-rw-r--r--dev-util/libtree/libtree-3.0.1.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/libtree/Manifest b/dev-util/libtree/Manifest
index 8970a0eb9c1a..11c6ad63baae 100644
--- a/dev-util/libtree/Manifest
+++ b/dev-util/libtree/Manifest
@@ -1,5 +1,7 @@
DIST libtree-2.0.0.tar.gz 161133 BLAKE2B cf681f06fef9dfb44ad6099a4b7ab950cb23aef052a180cdd646498ac0baacf0f0caa14bac6a629d2bac2bd638d4b6e5ad97dd0d705e4d681021a168a6753b0f SHA512 9272afd8540110f43ade864a2df58d8b8a7690c79cd29a9804b43e7e550bc05a4da530a763a27bd85a474673055e7a5ba63c0aa0bcaf8b246fbfc73a4f36c870
DIST libtree-3.0.0.tar.gz 78989 BLAKE2B e930d2e88898337425906a285ad5fb318e9b36a0dd6bbdade528fcfad21aff3d460e619ff2f4a4534b0a7b1439a2dbe62b19626ee85d17fbe9a36a7ddaa63aad SHA512 d249e46c9f20ba51133ef9754a944f67383e5043a7e2a715d0937b3f22ff10cf96a69690b592a5118b3eed73a05b73bfb061d2f72583ad2bb9da969294f622ab
+DIST libtree-3.0.1.tar.gz 79050 BLAKE2B d1b14512fd29054c9625311841a86089a576f783233a181005d9b3454689f8a58c585f16fe26ad3e1d26ae4552149517989401a7f97e08265cf093ffc8aa5aa3 SHA512 92975fc2e77ca7e68ea22866e3a82836e9dcd69409f3fe0f61852c43b9aba6ceb67d1619afb27adc68ddb1615bd24621e3a8de8858b5ce84a9bd670830852ba1
EBUILD libtree-2.0.0.ebuild 615 BLAKE2B 9c4452eba48044cc321b8f4c38c3b31cddb5261fab0369e9bf2e759f285e781f080b067dd492078a236fe2abb27aeb048fd32c7b438f000ac277dfaa1cdcb627 SHA512 3c2f2b1e64458695c1035f9b2f36d941a429edbff116f011712d5bc5b235651f47e5c8239beca0185b18fb389478b2c05908dea6bfc1ff31027d73022a49337f
EBUILD libtree-3.0.0.ebuild 569 BLAKE2B c6c0190fab6037a3f192fc4481adfa5533239b5c1a44f6942741816aeb1559ebd704376bdbb0c0ec2feb3aef39cfeb8f0986d4b9b433d42c7975ba74156519f7 SHA512 82252aa909946ee7f646431796e6739af70461d57cef3a4ab9fbed147c4178934aeaec0cb051f82083648d675633119edca270cfbce9f2ff4440a5f60802a2cd
+EBUILD libtree-3.0.1.ebuild 569 BLAKE2B fa62654c3f6111be583a93a9a26c33cf7f2d7ca2546e4ac94d6c1cb1ff9f7818a62be4b08cbc2763e6b7933c8d153a94c81a9f948ed8252e66d290e781af21ce SHA512 5413dd6ff2b2be20d280506f9943773bba66a2c4dd5a0d7a9f61555c084074e129b0f499c00102690195495d0bc5f52c2ca41787d3e5cb6ab9e1bdbd4fdc0811
MISC metadata.xml 319 BLAKE2B efc2cbcd041b25c841224ec0c4e5b536c6affe00038edce1a97384ed3bd640b439f5ae6439bfe839c0ab45de42f0d58ae0128706f35de4621aa45980e52adfc1 SHA512 1231843b9b1965567ba827dc32c395da10629fa3c5a0e45a9bbd65cb8c6da10bf3015cd11c255c5e10f20e98f3cd081c8bc70d3150529c26c429a2e16619410c
diff --git a/dev-util/libtree/libtree-3.0.1.ebuild b/dev-util/libtree/libtree-3.0.1.ebuild
new file mode 100644
index 000000000000..ac802156d332
--- /dev/null
+++ b/dev-util/libtree/libtree-3.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="ldd as a tree with an option to bundle dependencies into a single folder"
+HOMEPAGE="https://github.com/haampie/libtree"
+SRC_URI="https://github.com/haampie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# 3.0.0 rewrote in C; tests don't seem to pass yet
+RESTRICT="test"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}