summaryrefslogtreecommitdiff
path: root/dev-util/libtree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-util/libtree
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-util/libtree')
-rw-r--r--dev-util/libtree/Manifest3
-rw-r--r--dev-util/libtree/libtree-2.0.0.ebuild31
-rw-r--r--dev-util/libtree/metadata.xml11
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/libtree/Manifest b/dev-util/libtree/Manifest
new file mode 100644
index 000000000000..7d4bd0f7668d
--- /dev/null
+++ b/dev-util/libtree/Manifest
@@ -0,0 +1,3 @@
+DIST libtree-2.0.0.tar.gz 161133 BLAKE2B cf681f06fef9dfb44ad6099a4b7ab950cb23aef052a180cdd646498ac0baacf0f0caa14bac6a629d2bac2bd638d4b6e5ad97dd0d705e4d681021a168a6753b0f SHA512 9272afd8540110f43ade864a2df58d8b8a7690c79cd29a9804b43e7e550bc05a4da530a763a27bd85a474673055e7a5ba63c0aa0bcaf8b246fbfc73a4f36c870
+EBUILD libtree-2.0.0.ebuild 615 BLAKE2B 9c4452eba48044cc321b8f4c38c3b31cddb5261fab0369e9bf2e759f285e781f080b067dd492078a236fe2abb27aeb048fd32c7b438f000ac277dfaa1cdcb627 SHA512 3c2f2b1e64458695c1035f9b2f36d941a429edbff116f011712d5bc5b235651f47e5c8239beca0185b18fb389478b2c05908dea6bfc1ff31027d73022a49337f
+MISC metadata.xml 319 BLAKE2B efc2cbcd041b25c841224ec0c4e5b536c6affe00038edce1a97384ed3bd640b439f5ae6439bfe839c0ab45de42f0d58ae0128706f35de4621aa45980e52adfc1 SHA512 1231843b9b1965567ba827dc32c395da10629fa3c5a0e45a9bbd65cb8c6da10bf3015cd11c255c5e10f20e98f3cd081c8bc70d3150529c26c429a2e16619410c
diff --git a/dev-util/libtree/libtree-2.0.0.ebuild b/dev-util/libtree/libtree-2.0.0.ebuild
new file mode 100644
index 000000000000..a9152d7fe064
--- /dev/null
+++ b/dev-util/libtree/libtree-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ldd as a tree with an option to bundle dependencies into a single folder"
+HOMEPAGE="https://github.com/haampie/libtree"
+SRC_URI="https://github.com/haampie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/cxxopts
+ dev-cpp/elfio
+ dev-cpp/termcolor
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBTREE_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-util/libtree/metadata.xml b/dev-util/libtree/metadata.xml
new file mode 100644
index 000000000000..e63def80e5ba
--- /dev/null
+++ b/dev-util/libtree/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">haampie/libtree</remote-id>
+ </upstream>
+</pkgmetadata>