summaryrefslogtreecommitdiff
path: root/dev-util/librnp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
commit128025db16ea525715d1f5170c635c4f42ce4881 (patch)
tree07a1048840d97aefa9778386f8a8abc27940c708 /dev-util/librnp
parent37cf2a8dbadd546a550aac7c8079c3f77427cb63 (diff)
gentoo auto-resync : 13:04:2023 - 11:43:14
Diffstat (limited to 'dev-util/librnp')
-rw-r--r--dev-util/librnp/Manifest2
-rw-r--r--dev-util/librnp/librnp-0.16.3.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/librnp/Manifest b/dev-util/librnp/Manifest
index 4aa213b410de..529181bfc423 100644
--- a/dev-util/librnp/Manifest
+++ b/dev-util/librnp/Manifest
@@ -1,3 +1,5 @@
DIST librnp-0.16.2.tar.gz 2897137 BLAKE2B 5f756047506531e0ed3d431cebd3977f3492b464445f6dc54850badc795478f5d04ff036147e8212b4a3e2d4fd939f4bcf668e9a260c2e7fc616ef51dea02117 SHA512 5fd5fceb39429e130adafd4869d9a01149d9c08271770da4eedbe75910788f8256c8bf19e6bb0886a902b22dd5564eb93baddaf84689cbf5e6617674f4f0efac
+DIST librnp-0.16.3.tar.gz 2897854 BLAKE2B 71e39e810bdbee351c8136df1d11621daccb1738db691b99244ffe5bd2ea372c3ef520ade7cd63c38510fae0f252d5a1c2ceb44db3fbffbd64dfc10612341e29 SHA512 b133fb1f9aab6e9b5caecdcf0bd9f2c67a62a98543ca1ac6a7cf4a35b7a571d53e4fa99cefc98f8253117cf0de16194db309efa03bc40fd3556f9b84cf51a942
EBUILD librnp-0.16.2.ebuild 1621 BLAKE2B 36d97936371e4c8c4f4c6abf21c2f34eb39b113731a89a4d595a191eaaa745940c05818eef87cfd653615b17b3fdba776c7c61d658c07cf2a26cf5efb299304b SHA512 802d1f54b978f8940abc18fb09af1964288aaef944c5b6f09c506e071cea19bf68a9669df894f0427430a354057e1457e56642abe38a1d70ecaed86cd22805a7
+EBUILD librnp-0.16.3.ebuild 1668 BLAKE2B f5b05b73df42cde8eb00f7420d889b8a96173ae5c02fbb19c78ce8f83eab0d7fd90280159c2832469d15378dabe2a6a15cea0bed14736db802c3c90bc1f370c4 SHA512 9e29a81d077d5e646bff1aa4614ba0d06cd69c6f8385020c046c165fb47d8a054a5b2cce084a60caf4623a54d7ff3068ed2b63056c502f3888d2e573113f7b6c
MISC metadata.xml 430 BLAKE2B 739d6cddc56f385ad2b1679f6b3d9ba567ce77ec536894ca3861ad7ad127fd60c395db49b31d89963df12c03d8cf69fc6f083f5d3361b790079952c1e76ccf03 SHA512 ad7b3e6332741e1f2eae9e158d5ca767f5985a8f5c86eb5f21b7ee0214b9c7fdd2e90beddf1a9287218edf35aff39bd7ff1a4f1d15eb10552ab664738f8d1959
diff --git a/dev-util/librnp/librnp-0.16.3.ebuild b/dev-util/librnp/librnp-0.16.3.ebuild
new file mode 100644
index 000000000000..ca34a07b87f9
--- /dev/null
+++ b/dev-util/librnp/librnp-0.16.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="High performance C++ OpenPGP library"
+HOMEPAGE="https://www.rnpgp.org/ https://github.com/rnpgp/rnp"
+SRC_URI="https://github.com/rnpgp/rnp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2"
+SLOT="0/0.16.1"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="+botan man test"
+
+RDEPEND="app-arch/bzip2
+ dev-libs/json-c:=
+ sys-libs/zlib
+ botan? ( dev-libs/botan:2= )
+ !botan? ( >=dev-libs/openssl-1.1.1:= )"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+BDEPEND="man? ( dev-ruby/asciidoctor )"
+
+RESTRICT="!test? ( test )"
+S="${WORKDIR}/${P/*lib/}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test on off)
+
+ -DCRYPTO_BACKEND=$(usex botan botan openssl)
+
+ -DDOWNLOAD_GTEST=off
+ -DDOWNLOAD_RUBYRNP=off
+
+ -DENABLE_COVERAGE=off
+ -DENABLE_DOC=$(usex man on off)
+ -DENABLE_FUZZERS=off
+ -DENABLE_SANITIZERS=off
+ )
+
+ if use botan; then
+ local mycmakeargs+=(
+ -DENABLE_AEAD=on
+ -DENABLE_BRAINPOOL=on
+ -DENABLE_IDEA=on
+ -DENABLE_SM2=on
+ -DENABLE_TWOFISH=on
+ )
+
+ # OpenSSL support is still not as complete as botan.
+ # https://github.com/rnpgp/rnp/issues/1642 (v. 0.17.0),
+ # https://github.com/rnpgp/rnp/issues/1877 SM2,
+ # https://github.com/openssl/openssl/issues/2046 TWOFISH (won't be implemented).
+ else
+ local mycmakeargs+=(
+ -DENABLE_AEAD=off
+ -DENABLE_BRAINPOOL=on
+ -DENABLE_IDEA=on
+ -DENABLE_SM2=off
+ -DENABLE_TWOFISH=off
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/src/tests || die
+ ctest -j"${MAKEOPTS}" -R .* --output-on-failure || die
+}