summaryrefslogtreecommitdiff
path: root/dev-util/libabigail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-27 22:41:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-27 22:41:01 +0100
commitf660c6de84558324d784218831d8f0782ee41e2e (patch)
treec1f2aa79617d0ceaaff49d71603abc386aae2c37 /dev-util/libabigail
parent95461df035e3867364495f065e5e805bf629b2d7 (diff)
gentoo resync : 27.10.2021
Diffstat (limited to 'dev-util/libabigail')
-rw-r--r--dev-util/libabigail/Manifest2
-rw-r--r--dev-util/libabigail/libabigail-2.0.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-util/libabigail/Manifest b/dev-util/libabigail/Manifest
index fb3085b3c502..9303f291fe44 100644
--- a/dev-util/libabigail/Manifest
+++ b/dev-util/libabigail/Manifest
@@ -1,5 +1,7 @@
DIST libabigail-1.6.tar.gz 176133766 BLAKE2B 4a8fd6861f2213f45bbc5814a8a4e0941c236660ea6f84f09eedf6c08eff963c956f27967581501cd73b51057c3d36a74d53b6bf63d0be4d2c931d465d0564eb SHA512 2ba775bd836b53265dae60e66065fc2106e7f633e890cc70b6abacb8426e04ec0b7b38593c21336f5785cf5e4eb8d110fb15ce63124cddc59f660f31c7b25b3c
DIST libabigail-1.8.2.tar.gz 258919334 BLAKE2B 6e06c888dcc3f5e0fc5d4046e69f14ba06b3a78206f89e32e4687b07aae1e1d798582285cff5ac9f43d6ba326fe11ec11552eefb5ed05813c25785e337092ba2 SHA512 fa8edaf39632e26430481f15e962a098459eac087074e85ca055293ba324ec5944c45880fcb36f1c54a64652605a439cbf9247dfea9bfd3ec502cc7292dd1c8d
+DIST libabigail-2.0.tar.gz 286383045 BLAKE2B 2ba6f59bcd7a1484c4a60c6c9f212ad76af239a552d2cc9e47748e0db52363afadd7a99ef3e123c263de34b416f71b9d679bf2a5c542c419bb38ee75f3d5c57b SHA512 288f63f3495f0cd38258c50b78f30a573e43ab60494fefa22c8cba6d6776c5f94742ffea26297a232b78d25f6804f1b3f51febd59ec487733e6ef683cef2c180
EBUILD libabigail-1.6.ebuild 1505 BLAKE2B eaf813c7f56b0d703e03ae350885ed6beb54fa7dd08bc62eb58c7b935d4d4a9857f7c8f0e130ee74334bb52c1f967e334d835922ea52569f435df5857276adbf SHA512 5b6db24c5a22f369675f0a1e308ad42b4e79940a8e632503c28f43c528051227a2cb808e050c2cc5918fc519002bedcabb3f8a745bc7c3a125596650a57b84d4
EBUILD libabigail-1.8.2.ebuild 1513 BLAKE2B e54abef6af668ccc017e137c8e592f6371f9348667d06c0aa332a327ac322308c6e4b3ef02ead3c7afef2dc5b5ca1f4c422db54ce65a46d85ee26c56ccf0b706 SHA512 6efb448acfd4f8c201f0fbd3c3aa5c49d8fce8aafa1dd366e32f9205aa10cacf6ccbb316f1faabce30179cde75ac9146c067e226218f84734c3e743a79fd65c1
+EBUILD libabigail-2.0.ebuild 1511 BLAKE2B 1f55400229d03135d498d97f4ebf19ed6572d6be7e4a9c3c0ea076397023cbf5d7350555f2811b0102869f9235cf1a3a14f45ffed4c04ac12dd5551a3a10f63f SHA512 fe3c229ceb59618de0d6aba930405391b2142132f22ee049321a0ba14333b59f8955dc871039c29db0c95fc8dcc4c3e5a63bab208209cbafec80d98de78d6660
MISC metadata.xml 245 BLAKE2B 4ac08132cfdd18d0ef2c38470da5045bca296f4975a8fa1e7094c1f6f524ebf02103d487ae7d6d0bb1c912d46eb207a74a417bbdc10bc92499331112f15392e6 SHA512 fa5b2d519f191de35a1f8719e8ba7ea346c54173c797e152df2aeefda32dfb0e0741ff171b87e1ee835c1d5383f424b8bb276d597bdf2fe911525bd5719cab9d
diff --git a/dev-util/libabigail/libabigail-2.0.ebuild b/dev-util/libabigail/libabigail-2.0.ebuild
new file mode 100644
index 000000000000..16dce70710f0
--- /dev/null
+++ b/dev-util/libabigail/libabigail-2.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit autotools python-any-r1 out-of-source
+
+DESCRIPTION="Suite of tools for checking ABI differences between ELF objects"
+HOMEPAGE="https://sourceware.org/libabigail/"
+SRC_URI="https://mirrors.kernel.org/sourceware/libabigail/${P}.tar.gz"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/elfutils
+ dev-libs/libxml2:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ sys-apps/texinfo
+ )
+ test? ( ${PYTHON_DEPS} )"
+
+src_prepare() {
+ default
+ # need to run our autotools, due to ltmain.sh including Redhat calls:
+ # cannot read spec file '/usr/lib/rpm/redhat/redhat-hardened-ld': No such file or directory
+ eautoreconf
+}
+
+my_src_configure() {
+ econf \
+ --disable-deb \
+ --disable-fedabipkgdiff \
+ --disable-rpm \
+ --disable-rpm415 \
+ --disable-static \
+ --enable-bash-completion \
+ --enable-python3 \
+ $(use_enable doc apidoc) \
+ $(use_enable doc manual)
+}
+
+my_src_compile() {
+ default
+ use doc && emake doc
+}
+
+my_src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ doman doc/manuals/man/*
+ doinfo doc/manuals/texinfo/abigail.info
+
+ dodoc -r doc/manuals/html
+
+ docinto html/api
+ dodoc -r doc/api/html/.
+ fi
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}