summaryrefslogtreecommitdiff
path: root/dev-util/libabigail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-util/libabigail
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-util/libabigail')
-rw-r--r--dev-util/libabigail/Manifest3
-rw-r--r--dev-util/libabigail/libabigail-1.6.ebuild77
-rw-r--r--dev-util/libabigail/metadata.xml8
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-util/libabigail/Manifest b/dev-util/libabigail/Manifest
new file mode 100644
index 000000000000..8c4f14544dd7
--- /dev/null
+++ b/dev-util/libabigail/Manifest
@@ -0,0 +1,3 @@
+DIST libabigail-1.6.tar.gz 176133766 BLAKE2B 4a8fd6861f2213f45bbc5814a8a4e0941c236660ea6f84f09eedf6c08eff963c956f27967581501cd73b51057c3d36a74d53b6bf63d0be4d2c931d465d0564eb SHA512 2ba775bd836b53265dae60e66065fc2106e7f633e890cc70b6abacb8426e04ec0b7b38593c21336f5785cf5e4eb8d110fb15ce63124cddc59f660f31c7b25b3c
+EBUILD libabigail-1.6.ebuild 1505 BLAKE2B eaf813c7f56b0d703e03ae350885ed6beb54fa7dd08bc62eb58c7b935d4d4a9857f7c8f0e130ee74334bb52c1f967e334d835922ea52569f435df5857276adbf SHA512 5b6db24c5a22f369675f0a1e308ad42b4e79940a8e632503c28f43c528051227a2cb808e050c2cc5918fc519002bedcabb3f8a745bc7c3a125596650a57b84d4
+MISC metadata.xml 244 BLAKE2B bd2c6209566a4936a38d9109a9a533aa1669dd50701ff8a96d2a65411aa692517ab70cafd98afcad7058979d62f1a7ac796c5b99a520c0f6ca1ed92cf9e0e207 SHA512 57959095dc10704e073e5517ac49ceee80e42fb1cc3f26b1b7308f872ffda810ce42e0b80ea6da57faa7a759878a9b8d2476fe351fecac1450f9c83751802787
diff --git a/dev-util/libabigail/libabigail-1.6.ebuild b/dev-util/libabigail/libabigail-1.6.ebuild
new file mode 100644
index 000000000000..639ff46eaed0
--- /dev/null
+++ b/dev-util/libabigail/libabigail-1.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit autotools python-any-r1 out-of-source
+
+DESCRIPTION="Suite of tools for checking ABI differences between ELF objects"
+HOMEPAGE="https://sourceware.org/libabigail/"
+SRC_URI="https://mirrors.kernel.org/sourceware/libabigail/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/elfutils:=
+ dev-libs/libxml2:2="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ sys-apps/texinfo
+ )
+ test? ( ${PYTHON_DEPS} )"
+
+src_prepare() {
+ default
+ # need to run our autotools, due to ltmain.sh including Redhat calls:
+ # cannot read spec file '/usr/lib/rpm/redhat/redhat-hardened-ld': No such file or directory
+ eautoreconf
+}
+
+my_src_configure() {
+ econf \
+ --disable-deb \
+ --disable-fedabipkgdiff \
+ --disable-rpm \
+ --disable-static \
+ --disable-zip-archive \
+ --enable-bash-completion \
+ --enable-cxx11 \
+ --enable-python3 \
+ $(use_enable doc apidoc) \
+ $(use_enable doc manual)
+}
+
+my_src_compile() {
+ default
+ use doc && emake doc
+}
+
+my_src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ doman doc/manuals/man/*
+ doinfo doc/manuals/texinfo/abigail.info
+
+ dodoc -r doc/manuals/html
+
+ docinto html/api
+ dodoc -r doc/api/html/.
+ fi
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-util/libabigail/metadata.xml b/dev-util/libabigail/metadata.xml
new file mode 100644
index 000000000000..70f78a5392df
--- /dev/null
+++ b/dev-util/libabigail/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>soap@gentoo.org</email>
+ <name>David Seifert</name>
+ </maintainer>
+</pkgmetadata>