summaryrefslogtreecommitdiff
path: root/dev-util/lcov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /dev-util/lcov
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'dev-util/lcov')
-rw-r--r--dev-util/lcov/Manifest1
-rw-r--r--dev-util/lcov/files/lcov-1.13-gcc-8.patch91
2 files changed, 0 insertions, 92 deletions
diff --git a/dev-util/lcov/Manifest b/dev-util/lcov/Manifest
index 87dc7a130e0d..9834de865e64 100644
--- a/dev-util/lcov/Manifest
+++ b/dev-util/lcov/Manifest
@@ -1,4 +1,3 @@
-AUX lcov-1.13-gcc-8.patch 3049 BLAKE2B ec0e22a61851ec2acbb0ac8909f1fc91d57d8dc2914583cf70cfbd7c08153c0c87a76d7f30e41f3660d4ecd9e76b3f06fb562865fc79474019f29c83602728c4 SHA512 f3598e28e98e97d3d1eec8ed4168996623cf920f94870cce4e731de2e1b0925a786dc8cbaf9d70379fc4e73f4f26f3a9405b2077c5246dcd66cc0eab25625b94
DIST lcov-1.15.tar.gz 190487 BLAKE2B 2d6478caae488b84c74a3f7b489013b065b3e8fb106a6e8c5f413ffe87be7f4530aade8d2b5df5b8193949d60f49d5255b4eddb0cd5f1cab6f450ba2f97426ab SHA512 dda0eadbd0ea2093f17cba039309ccda3dbcb7266d083b46bda61e02cd7f049d66de49be1e005157c3e5af910d2703ffbc9cfe7f1242bd67b9787f8508e4d052
EBUILD lcov-1.15.ebuild 963 BLAKE2B 12eb656eb9177ee422a10eb25188a9f6c53817e2251264a397e3a08d220970a848ffb69aaae4e40c986d66a186b52f696c9b1dd9319d696d45b1a12f06a70e9f SHA512 e9602ace4785304ae11ea186f3cb670ec1b192102d011ad1d9c8fd3feeeebdcf6c2ba23c9652f442c10a226216484a31ffb866cc63b2abbadc58cacdd95b8cec
EBUILD lcov-9999.ebuild 920 BLAKE2B c39cab5754c576571ad3ce4b3151b987af87973a896695a3f25edaf95fea78f2ea812243e047aa6564a25dc52d06d8b7566c23025daa0fcd00bb6e2f54bf5f43 SHA512 b1532e9099ed0a39ad83bd96ceb1b6adf4b6bd4a558678b2a9b32246137996657343e7f9af3b721d40726bd14ee4ac1e76e77b8c8a2f9aa57466690709862369
diff --git a/dev-util/lcov/files/lcov-1.13-gcc-8.patch b/dev-util/lcov/files/lcov-1.13-gcc-8.patch
deleted file mode 100644
index b67ca411bdaf..000000000000
--- a/dev-util/lcov/files/lcov-1.13-gcc-8.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From a5dd9529f9232b8d901a4d6eb9ae54cae179e5b3 Mon Sep 17 00:00:00 2001
-From: Peter Oberparleiter <oberpar@linux.vnet.ibm.com>
-Date: Wed, 7 Mar 2018 14:18:55 +0100
-Subject: [PATCH] geninfo: Add gcc 8 support
-
-Fix errors and incorrect data when trying to collect coverage data
-for programs compiled with gcc 8.
-
-Covers the following gcov-related changes in gcc:
-
-.gcov-file format:
- - Line coverage data can appear multiple times for the same line
- - Line coverage count can be suffixed by '*' to indicated unexecuted
- basic blocks in that line
-
-.gcno-file format:
- - new header field 'support unexecuted blocks flag'
- - new function record fields 'column number', 'ending line number',
- and 'compiler-generated entity flag'
-
-Signed-off-by: Peter Oberparleiter <oberpar@linux.vnet.ibm.com>
----
- bin/geninfo | 20 ++++++++++++++++++++
- 1 file changed, 20 insertions(+)
-
-diff --git a/bin/geninfo b/bin/geninfo
-index 8562560..ef6a818 100755
---- a/bin/geninfo
-+++ b/bin/geninfo
-@@ -68,6 +68,7 @@ our $lcov_url = "http://ltp.sourceforge.net/coverage/lcov.php";
- our $gcov_tool = "gcov";
- our $tool_name = basename($0);
-
-+our $GCOV_VERSION_8_0_0 = 0x80000;
- our $GCOV_VERSION_4_7_0 = 0x40700;
- our $GCOV_VERSION_3_4_0 = 0x30400;
- our $GCOV_VERSION_3_3_0 = 0x30300;
-@@ -1934,6 +1935,9 @@ sub read_gcov_file($)
- {
- my ($count, $line, $code) = ($1, $2, $3);
-
-+ # Skip instance-specific counts
-+ next if ($line == $last_line);
-+
- $last_line = $line;
- $last_block = $UNNAMED_BLOCK;
- # Check for exclusion markers
-@@ -1963,6 +1967,9 @@ sub read_gcov_file($)
- }
- }
-
-+ # Strip unexecuted basic block marker
-+ $count =~ s/\*$//;
-+
- # <exec count>:<line number>:<source code>
- if ($line eq "0")
- {
-@@ -3537,6 +3544,10 @@ sub read_gcno_function_record(*$$$$$)
- graph_expect("function name");
- $function = read_gcno_string($handle, $big_endian);
- return undef if (!defined($function));
-+ if ($version >= $GCOV_VERSION_8_0_0) {
-+ graph_skip($handle, 4, "compiler-generated entity flag")
-+ or return undef;
-+ }
- # Read filename
- graph_expect("filename");
- $filename = read_gcno_string($handle, $big_endian);
-@@ -3544,6 +3555,11 @@ sub read_gcno_function_record(*$$$$$)
- # Read first line number
- $lineno = read_gcno_value($handle, $big_endian, "initial line number");
- return undef if (!defined($lineno));
-+ # Skip column and ending line number
-+ if ($version >= $GCOV_VERSION_8_0_0) {
-+ graph_skip($handle, 4, "column number") or return undef;
-+ graph_skip($handle, 4, "ending line number") or return undef;
-+ }
- # Add to list
- push(@{$bb->{$function}->{$filename}}, $lineno);
- graph_add_order($fileorder, $function, $filename);
-@@ -3631,6 +3647,10 @@ sub read_gcno($)
- debug(sprintf("found version 0x%08x\n", $version));
- # Skip stamp
- graph_skip(*HANDLE, 4, "file timestamp") or goto incomplete;
-+ if ($version >= $GCOV_VERSION_8_0_0) {
-+ graph_skip(*HANDLE, 4, "support unexecuted blocks flag")
-+ or goto incomplete;
-+ }
- while (!eof(HANDLE)) {
- my $next_pos;
- my $curr_pos;