summaryrefslogtreecommitdiff
path: root/dev-util/lcov/lcov-1.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-util/lcov/lcov-1.15.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-util/lcov/lcov-1.15.ebuild')
-rw-r--r--dev-util/lcov/lcov-1.15.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/lcov/lcov-1.15.ebuild b/dev-util/lcov/lcov-1.15.ebuild
new file mode 100644
index 000000000000..aaf14998d4b6
--- /dev/null
+++ b/dev-util/lcov/lcov-1.15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/linux-test-project/lcov/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
+fi
+
+inherit optfeature prefix
+
+DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
+HOMEPAGE="http://ltp.sourceforge.net/coverage/lcov.php"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/JSON
+ dev-perl/PerlIO-gzip
+"
+
+src_prepare() {
+ default
+ if use prefix; then
+ hprefixify bin/*.{pl,sh}
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake -j1 PREFIX="${ED}/usr" CFG_DIR="${ED}/etc" install
+}
+
+pkg_postinst() {
+ elog "Optional features:"
+ optfeature "png output support" dev-perl/GD[png]
+}