summaryrefslogtreecommitdiff
path: root/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild')
-rw-r--r--dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild b/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
index b059c970683b..d67368a4579c 100644
--- a/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
+++ b/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake qmake-utils
DESCRIPTION="Framework for creating Qt State Machine metacode using graphical user interfaces"
HOMEPAGE="https://github.com/KDAB/KDStateMachineEditor"
-if [[ ${PV} == 9999 ]] ; then
+if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/KDAB/KDStateMachineEditor.git"
else
@@ -17,9 +17,10 @@ else
fi
LICENSE="GPL-2+"
+SLOT="0"
IUSE="doc test"
+
RESTRICT="!test? ( test )"
-SLOT="0"
RDEPEND="
dev-qt/qtcore:5
@@ -45,6 +46,7 @@ BDEPEND="
src_configure() {
local mycmakeargs=(
-DBUILD_EXAMPLES=OFF
+ -DWITH_INTERNAL_GRAPHVIZ=OFF
-DBUILD_DOCS=$(usex doc)
-DBUILD_TESTING=$(usex test)
-DECM_MKSPECS_INSTALL_DIR=$(qt5_get_mkspecsdir)/modules