summaryrefslogtreecommitdiff
path: root/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild')
-rw-r--r--dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild b/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
new file mode 100644
index 000000000000..5711b07e35a0
--- /dev/null
+++ b/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kde5-functions
+
+DESCRIPTION="Framework for creating Qt State Machine metacode using graphical user interfaces"
+HOMEPAGE="https://github.com/KDAB/KDStateMachineEditor"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/KDAB/KDStateMachineEditor.git"
+else
+ SRC_URI="https://github.com/KDAB/KDStateMachineEditor/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+IUSE="doc test"
+SLOT="0"
+
+RDEPEND="
+ $(add_qt_dep qtcore)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+"
+
+DEPEND="${RDEPEND}
+ doc? (
+ $(add_qt_dep qthelp)
+ app-doc/doxygen
+ )
+ test? (
+ $(add_qt_dep qttest)
+ $(add_qt_dep qtxmlpatterns)
+ )
+ media-gfx/graphviz
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF
+ -DBUILD_DOCS=$(usex doc)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}