summaryrefslogtreecommitdiff
path: root/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild')
-rw-r--r--dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild b/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
new file mode 100644
index 000000000000..879b2ad3bded
--- /dev/null
+++ b/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kde5-functions
+
+DESCRIPTION="Framework for creating Qt State Machine metacode using graphical user interfaces"
+HOMEPAGE="https://github.com/KDAB/KDStateMachineEditor"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/KDAB/KDStateMachineEditor.git"
+else
+ SRC_URI="https://github.com/KDAB/KDStateMachineEditor/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+IUSE="doc test"
+SLOT="0"
+
+RDEPEND="
+ $(add_qt_dep qtcore)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+"
+
+DEPEND="${RDEPEND}
+ doc? ( $(add_qt_dep qthelp)
+ app-doc/doxygen )
+ test? ( $(add_qt_dep qttest)
+ $(add_qt_dep qtxmlpatterns) )
+ media-gfx/graphviz
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF
+ -DBUILD_DOCS=$(usex doc)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}