summaryrefslogtreecommitdiff
path: root/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild')
-rw-r--r--dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild b/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
deleted file mode 100644
index 5711b07e35a0..000000000000
--- a/dev-util/kdstatemachineeditor/kdstatemachineeditor-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils kde5-functions
-
-DESCRIPTION="Framework for creating Qt State Machine metacode using graphical user interfaces"
-HOMEPAGE="https://github.com/KDAB/KDStateMachineEditor"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/KDAB/KDStateMachineEditor.git"
-else
- SRC_URI="https://github.com/KDAB/KDStateMachineEditor/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-2+"
-IUSE="doc test"
-SLOT="0"
-
-RDEPEND="
- $(add_qt_dep qtcore)
- $(add_qt_dep qtdeclarative 'widgets')
- $(add_qt_dep qtgui)
- $(add_qt_dep qtnetwork)
- $(add_qt_dep qtwidgets)
-"
-
-DEPEND="${RDEPEND}
- doc? (
- $(add_qt_dep qthelp)
- app-doc/doxygen
- )
- test? (
- $(add_qt_dep qttest)
- $(add_qt_dep qtxmlpatterns)
- )
- media-gfx/graphviz
-"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_EXAMPLES=OFF
- -DBUILD_DOCS=$(usex doc)
- -DBUILD_TESTING=$(usex test)
- )
- cmake-utils_src_configure
-}