summaryrefslogtreecommitdiff
path: root/dev-util/kcov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/kcov
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/kcov')
-rw-r--r--dev-util/kcov/Manifest6
-rw-r--r--dev-util/kcov/kcov-33.ebuild21
-rw-r--r--dev-util/kcov/kcov-34.ebuild21
-rw-r--r--dev-util/kcov/kcov-9999.ebuild27
-rw-r--r--dev-util/kcov/metadata.xml11
5 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/kcov/Manifest b/dev-util/kcov/Manifest
new file mode 100644
index 000000000000..11e48da0806c
--- /dev/null
+++ b/dev-util/kcov/Manifest
@@ -0,0 +1,6 @@
+DIST kcov-33.tar.gz 276028 BLAKE2B bed7f2b2feb3ecb1a861928306626b44904af52f30d5721cd0e6ba9ad5db5edb1ffb51fd64ab0fba5f99fc0329bbe87949b901bc73e2299c2075817f606113aa SHA512 e35ba3c4dc320cef0cde097cfa2c4067ec6bf86a5ee797d3ec111facffa036da4fc4d403e63bd3767d03eac511987592e77ed61810605f8e2da77c26570e245c
+DIST kcov-34.tar.gz 296345 BLAKE2B de6acbecd35b1d85a4a0f9f43fdf5dcb09331f88622a236fee672a8624c77baf4a8589d61aaecfb51220b83d28d98426ed32bfb345b717bb13fb180f479cc371 SHA512 63ea8e47f00e53b55be4c37697a7f0b78c15f887a40fc0679d7e92f1561bd379a526a82179ee243838fe6f6bd5b89c9eb76716cdb5add7bfb0f312176422a346
+EBUILD kcov-33.ebuild 509 BLAKE2B 8e9bb470e023a442d4aeedc2ba564d8ad8c9a2c40c2619b28b130a14b225ab49ec619aa161444ef31d078dd49226c159be28a11833a8dbbebc92dd7ef748f2ef SHA512 7cbdaf21d0b35a72f994c05b1aff180b9f805d7bfb05f1af89e7d5d33db9543bd1cd468813c8c5518305fa0de3926ec1b3d8b093badfabf11df53811086a7a58
+EBUILD kcov-34.ebuild 509 BLAKE2B 8e9bb470e023a442d4aeedc2ba564d8ad8c9a2c40c2619b28b130a14b225ab49ec619aa161444ef31d078dd49226c159be28a11833a8dbbebc92dd7ef748f2ef SHA512 7cbdaf21d0b35a72f994c05b1aff180b9f805d7bfb05f1af89e7d5d33db9543bd1cd468813c8c5518305fa0de3926ec1b3d8b093badfabf11df53811086a7a58
+EBUILD kcov-9999.ebuild 638 BLAKE2B fdd240a4bf38de8939b29ba7c04c1f29fe8977a074fb2c35bf23c80ac34539da1a0f39d60073a785d2850194e92d03f8618e6169ab00706cb0b686dd458ba5ce SHA512 cec899ac8769080dfa88b1d34d9f4a0b2da654da9712a4236cc343533e3bc33815159ef84074c843eba3053ee672f034ac2c439e9431ae2e0a0b4eac5f584eca
+MISC metadata.xml 334 BLAKE2B 49f7a7004704c8531accf4ab5979f0823e400f8bb8e79c987091b02e8abf7f288bdeb6eb9c65953605bf95a8eb07fdf9952c1c905a8f588225780d3ddef3b3aa SHA512 1a6d96440ff3def1c7fd765dac9c4f8240b36ce918c6c8d0803b2d2a465be5b571e31a2bdc4540cffc485eefb78e65f7ec5b30300918571e1d641112a078c7b3
diff --git a/dev-util/kcov/kcov-33.ebuild b/dev-util/kcov/kcov-33.ebuild
new file mode 100644
index 000000000000..7f1e7488e3b2
--- /dev/null
+++ b/dev-util/kcov/kcov-33.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Kcov is a code coverage tester for compiled languages, Python and Bash"
+HOMEPAGE="https://github.com/SimonKagstrom/kcov"
+SRC_URI="https://github.com/SimonKagstrom/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/elfutils
+ net-misc/curl
+ sys-devel/binutils:*
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
diff --git a/dev-util/kcov/kcov-34.ebuild b/dev-util/kcov/kcov-34.ebuild
new file mode 100644
index 000000000000..7f1e7488e3b2
--- /dev/null
+++ b/dev-util/kcov/kcov-34.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Kcov is a code coverage tester for compiled languages, Python and Bash"
+HOMEPAGE="https://github.com/SimonKagstrom/kcov"
+SRC_URI="https://github.com/SimonKagstrom/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/elfutils
+ net-misc/curl
+ sys-devel/binutils:*
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
diff --git a/dev-util/kcov/kcov-9999.ebuild b/dev-util/kcov/kcov-9999.ebuild
new file mode 100644
index 000000000000..eec056058ef3
--- /dev/null
+++ b/dev-util/kcov/kcov-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Kcov is a code coverage tester for compiled languages, Python and Bash"
+HOMEPAGE="https://github.com/SimonKagstrom/kcov"
+LICENSE="GPL-2"
+SLOT="0"
+
+if [ "${PV}" -eq 9999 ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SimonKagstrom/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/SimonKagstrom/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ dev-libs/elfutils
+ net-misc/curl
+ sys-devel/binutils:*
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
diff --git a/dev-util/kcov/metadata.xml b/dev-util/kcov/metadata.xml
new file mode 100644
index 000000000000..bbb53844e2b2
--- /dev/null
+++ b/dev-util/kcov/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>wizardedit@gentoo.org</email>
+ <name>Austin English</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">SimonKagstrom/kcov</remote-id>
+ </upstream>
+</pkgmetadata>