summaryrefslogtreecommitdiff
path: root/dev-util/kbuild/kbuild-0.1.9998.3499.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-util/kbuild/kbuild-0.1.9998.3499.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-util/kbuild/kbuild-0.1.9998.3499.ebuild')
-rw-r--r--dev-util/kbuild/kbuild-0.1.9998.3499.ebuild21
1 files changed, 20 insertions, 1 deletions
diff --git a/dev-util/kbuild/kbuild-0.1.9998.3499.ebuild b/dev-util/kbuild/kbuild-0.1.9998.3499.ebuild
index 574abc5324a7..ef85feb53592 100644
--- a/dev-util/kbuild/kbuild-0.1.9998.3499.ebuild
+++ b/dev-util/kbuild/kbuild-0.1.9998.3499.ebuild
@@ -65,7 +65,26 @@ src_prepare() {
}
src_compile() {
- kBuild/env.sh --full emake -f bootstrap.gmk AUTORECONF=true AR="$(tc-getAR)" \
+ if [[ -z ${YACC} ]] ; then
+ # If the user hasn't picked one, let's prefer byacc > yacc > old bison for now.
+ # See bug #734354 - bison doesn't work here.
+ # We can remove this once Bison works again!
+ if has_version -b "dev-util/byacc" ; then
+ export YACC=byacc
+ elif has_version -b "dev-util/yacc" ; then
+ export YACC=yacc
+ elif has_version -b "<sys-devel/bison-3.7" ; then
+ export YACC=bison
+ else
+ die "This case shouldn't be possible; no suitable YACC impl installed."
+ fi
+
+ einfo "Chosen YACC=${YACC} for build..."
+ else
+ einfo "Chosen user-provided YACC=${YACC} for build..."
+ fi
+
+ kBuild/env.sh --full emake -f bootstrap.gmk AUTORECONF=true AR="$(tc-getAR)" YACC="${YACC}" \
|| die "bootstrap failed"
}