summaryrefslogtreecommitdiff
path: root/dev-util/jfrog-cli/jfrog-cli-2.25.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-03 22:19:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-03 22:19:54 +0100
commit71f9cc21aab4168093940b3d2e267444d712bff5 (patch)
tree15406e14be0cd3cfbafe191468b8825b3ccc1855 /dev-util/jfrog-cli/jfrog-cli-2.25.2.ebuild
parent312456186919deebd1ea3b34b9e26b1e15ebd5b6 (diff)
gentoo auto-resync : 03:09:2022 - 22:19:54
Diffstat (limited to 'dev-util/jfrog-cli/jfrog-cli-2.25.2.ebuild')
-rw-r--r--dev-util/jfrog-cli/jfrog-cli-2.25.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/jfrog-cli/jfrog-cli-2.25.2.ebuild b/dev-util/jfrog-cli/jfrog-cli-2.25.2.ebuild
new file mode 100644
index 000000000000..8f8fecf94d4b
--- /dev/null
+++ b/dev-util/jfrog-cli/jfrog-cli-2.25.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Command line utility for operations on container images and image repositories"
+HOMEPAGE="https://github.com/jfrog/jfrog-cli"
+SRC_URI="https://github.com/jfrog/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ build/build.sh jfrog || die
+}
+
+src_install() {
+ dobin jfrog
+ einstalldocs
+}