summaryrefslogtreecommitdiff
path: root/dev-util/itstool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /dev-util/itstool
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'dev-util/itstool')
-rw-r--r--dev-util/itstool/Manifest2
-rw-r--r--dev-util/itstool/itstool-2.0.6.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/itstool/Manifest b/dev-util/itstool/Manifest
index bdf59dad2f22..21d5c5a2c45b 100644
--- a/dev-util/itstool/Manifest
+++ b/dev-util/itstool/Manifest
@@ -1,3 +1,5 @@
DIST itstool-2.0.2.tar.bz2 96748 BLAKE2B 7eb8f52c233878a35c01b7eea51c46f9700e9de827d38df41bb3ea78ca4ef284ab59c423aaf9876fceef023cb9d13d2d50c9ab57caff9e5fad217363412cf472 SHA512 b7915c4d463fe5969e282029c2080730c78e18d2d5878da53c6a370f471056b51a7b3f3c08417b801212ba674f55548a112a12a9d81634f60d1e52a8a47a4aa2
+DIST itstool-2.0.6.tar.bz2 103067 BLAKE2B 72d3254cb88ef9d02f9b3509a46c2208e98bf6327f139e5d29b99cc6d80651bd41ea3bfb78e48e23cf7c217770cd8c6c74b00946ad9d2608a92925e43457edf0 SHA512 51058bdcb208f6fb84810f71f9bf67e42b00bf157a9756be45f060849c0aff36f695f4403404193720d4446818fa77de61fa94eed9e8789d26c07a2926072eb7
EBUILD itstool-2.0.2.ebuild 836 BLAKE2B 9c83e097e2e201d434041502e38919c9eb55164d6b5e0f55ec6a32335d9bec181847c2ba65618e32b8ffae4f01b230b188ae44ab88d282f8ae83dae594359997 SHA512 347daaa09aef5501f3f5fa34b3127608b8d09135f0b12c5d47c2d714480063701225656892ec10ca4ee6a8213f71151becb790bc74f1e359e3b5c0595034e47d
+EBUILD itstool-2.0.6.ebuild 889 BLAKE2B 6596b2c339869388a0405ce7e9f775d98c39550e760c4dd29a66362f933170837ce69193ecba99816c61fcf0b3721136abadf0cb655eb580171b22b6fbcd6f06 SHA512 a4c791bf921ca895b5fd23a34705b7c153c013cf40abcfef4307ba069d85c72d47c4092c8cb65be21faadb209efd7a91f176173e10d245275e5e370acf74a05a
MISC metadata.xml 525 BLAKE2B a7e426bd9dd273bed10ad74315547eb758df04ceb7ee6ef66f643ba23e60ad8b9c80aa344688e4af7a16fd699a500cf7ceb9d24eb94a930eebf1637e09919a5f SHA512 ad9928fa0359257e3418c0fb6bba6c416fc4505911f35e97377ef7c1426e228b34312fc3156e98f3657974f1156ee2bdc58bbb4b51903bb40b10c97b0714b39b
diff --git a/dev-util/itstool/itstool-2.0.6.ebuild b/dev-util/itstool/itstool-2.0.6.ebuild
new file mode 100644
index 000000000000..0cd59f921282
--- /dev/null
+++ b/dev-util/itstool/itstool-2.0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="xml"
+
+inherit python-single-r1
+
+DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
+HOMEPAGE="http://itstool.org/"
+SRC_URI="http://files.itstool.org/itstool/${P}.tar.bz2"
+
+# files in /usr/share/itstool/its are under a special exception || GPL-3+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+DOCS=(ChangeLog NEWS) # AUTHORS, README are empty
+
+src_test() {
+ :
+ #"${PYTHON}" tests/run_tests.py || die "test suite failed" # Test suite not shipped in tarball
+}