summaryrefslogtreecommitdiff
path: root/dev-util/its4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/its4
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/its4')
-rw-r--r--dev-util/its4/Manifest4
-rw-r--r--dev-util/its4/its4-1.1.1-r1.ebuild45
-rw-r--r--dev-util/its4/its4-1.1.1.ebuild36
-rw-r--r--dev-util/its4/metadata.xml14
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-util/its4/Manifest b/dev-util/its4/Manifest
new file mode 100644
index 000000000000..d5a20ce399da
--- /dev/null
+++ b/dev-util/its4/Manifest
@@ -0,0 +1,4 @@
+DIST its4-1.1.1.tgz 59759 BLAKE2B 87c616dd7e2a5d3519f8827932c4d17d50dc7646097ba3aa6a8ebf29434671e560c0ba9949f370de8b26da9af9855a1fa16117d0a5a64b6098945e4292c8a33f SHA512 c7bfa71eba114ab3aac586dfa5f30c7a935f06d72b78bae3c3d464f591085cf3419a1d23ab951376bd9c2d7e436711a45c9f5047c3125df5d731b746412be0f6
+EBUILD its4-1.1.1-r1.ebuild 1084 BLAKE2B 7dbf0259667fb26958f5c250c3ccc1605dd719a1a75827b92414720ee88d85391adbbfed4f66fd928a714a1e34039f117797c61869a990c4ad0e46ac0e0a4134 SHA512 6f3a6660d487611f77a7bc9a3e31d231c021df19476f4fd114ccba301ed9695200dc32c830747aa29147f4589b37f45a7a6590d1ec8a4033c55f55b112c40639
+EBUILD its4-1.1.1.ebuild 933 BLAKE2B f88272743d439b4cfeb0a33a34c9c82d06cdcfc5971f79317c906cb51d2ee4f7f2be4e59c5755d49bef8ba0bd3a3713a1c53f26111c3f6df307c0f933d2ab216 SHA512 819a8e783e85d6c22f8b194dabfef204a63c11aa5b1c3494a254d680ef77592052dc4e83caa3db6d3344e66868a58b25f40af6d02df0b3d299851abd6494263f
+MISC metadata.xml 570 BLAKE2B 79fe1782f1d7fc7700188ccd3af2874267cc0419fd910b47f1b102c4f6cee88085ea09d18f98dbe1e539334e7a17de22bc66f14363e453ea3cf6c16ba9928481 SHA512 3b626c494c1b00c1032825afcf19a4b6aadd233588ae59bd8bad858d21bce920a0a41de5b51db8d6b196d1b3781389aadae2fed6e25093be930c13a44c2f224a
diff --git a/dev-util/its4/its4-1.1.1-r1.ebuild b/dev-util/its4/its4-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..0b5017ca8e43
--- /dev/null
+++ b/dev-util/its4/its4-1.1.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="ITS4: Software Security Tool"
+HOMEPAGE="http://www.cigital.com/its4/"
+SRC_URI="https://dev.gentoo.org/~robbat2/distfiles/${P}.tgz"
+LICENSE="ITS4"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e 's,iostream.h,iostream,g'\
+ "${S}"/configure || die
+ sed -i \
+ -e 's/$(CC) -o/$(CC) $(OPTIMIZATION) $(EXTRA_FLAGS) -o/' \
+ "${S}"/Makefile.in || die
+}
+
+src_configure() {
+ # WARNING
+ # non-standard configure
+ # do NOT use econf
+ ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share/its4 || die "configure failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" OPTIMIZATION="${CXXFLAGS}" EXTRA_FLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ # WARNING
+ # non-standard, do NOT use einstall or 'make install DESTDIR=...'
+ make install INSTALL_BINDIR="${D}/usr/bin" INSTALL_MANDIR="${D}/usr/share/man" INSTALL_DATADIR="${D}/usr/share/its4" || die "install failed"
+}
diff --git a/dev-util/its4/its4-1.1.1.ebuild b/dev-util/its4/its4-1.1.1.ebuild
new file mode 100644
index 000000000000..9ddd852df65d
--- /dev/null
+++ b/dev-util/its4/its4-1.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+DESCRIPTION="ITS4: Software Security Tool"
+HOMEPAGE="http://www.cigital.com/its4/"
+SRC_URI="https://dev.gentoo.org/~robbat2/distfiles/${P}.tgz"
+LICENSE="ITS4"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE=""
+DEPEND="sys-devel/gcc"
+#RDEPEND=""
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e 's,iostream.h,iostream,g'\
+ "${S}"/configure
+}
+
+src_compile() {
+ # WARNING
+ # non-standard configure
+ # do NOT use econf
+ ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share/its4 || die "configure failed"
+ emake OPTIMIZATION="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ # WARNING
+ # non-standard, do NOT use einstall or 'make install DESTDIR=...'
+ make install INSTALL_BINDIR="${D}/usr/bin" INSTALL_MANDIR="${D}/usr/share/man" INSTALL_DATADIR="${D}/usr/share/its4" || die "install failed"
+}
diff --git a/dev-util/its4/metadata.xml b/dev-util/its4/metadata.xml
new file mode 100644
index 000000000000..a2b4b8254df1
--- /dev/null
+++ b/dev-util/its4/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+<longdescription>
+ITS4 scans source code, looking for function calls that are potentially
+dangerous. For some calls, ITS4 tries to perform some code analysis to
+determine how risky the call is. In each case, ITS4 provides a problem report,
+including a short description of the potential problem and suggestions on how
+to fix the code.
+</longdescription>
+</pkgmetadata>