summaryrefslogtreecommitdiff
path: root/dev-util/intel-graphics-system-controller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-31 02:18:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-31 02:18:46 +0000
commitd897af505afa85942967dd218e3005a4ad906e5a (patch)
treed4f9a7f725a474e5a863ef6371652e852076df6b /dev-util/intel-graphics-system-controller
parentb449f73a7f391721e624420ba791536e3d6b17a8 (diff)
gentoo auto-resync : 31:12:2022 - 02:18:46
Diffstat (limited to 'dev-util/intel-graphics-system-controller')
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest2
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.6.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index d873402a18a4..d29de358bc91 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1,3 +1,5 @@
DIST intel-graphics-system-controller-0.8.4.tar.gz 173733 BLAKE2B c51f21bd2093d44c12ce10b4e5990a4428294093c6a8ccd90b01be30d918ac0898ea57b68ad004f4f477a7049e5060521c7fb1547d09f6e30cae8eab41090a69 SHA512 948c2043765c7a5b5dd9c350474725871601a76d292fd34c57c81b492945107ba2519b6a3f113cefed158adb7ac61164e85284be4683d1f48870650fdba969ad
+DIST intel-graphics-system-controller-0.8.6.tar.gz 179906 BLAKE2B cadbcb559418f5e6164002cdff1dea2b8a0cec946fd0128c4f374f9b58d5086e9aba3cc97a05641be0255d848e8acf3429df16ca7d70debfff3a282445a7ca3f SHA512 40b89f54754fba3a5cf43c4cc822ec5ea0506cd854b0a85bb29e03370cbb25638ab67b8a568fe6f4d7dd2e41e7f302c550e6d4955b6e6fbf4df0d512a3afe64b
EBUILD intel-graphics-system-controller-0.8.4.ebuild 1082 BLAKE2B b1de0cfda977845ba15dc491bdf6d1191293cf1ace5777bbfeac4f994d2923b6decc2d13869cca507cc9a290a542bcd2b89c99cb530344c494808af21eb09dff SHA512 02a3189921927cbc955864f8a35ef2c48d1e5d650f1de54342fe71474c5a8fe3eaeb89c8d7a086573635d6d7b6a4abbfdd61d84e7361697a903cdf1641385f0e
+EBUILD intel-graphics-system-controller-0.8.6.ebuild 1082 BLAKE2B b1de0cfda977845ba15dc491bdf6d1191293cf1ace5777bbfeac4f994d2923b6decc2d13869cca507cc9a290a542bcd2b89c99cb530344c494808af21eb09dff SHA512 02a3189921927cbc955864f8a35ef2c48d1e5d650f1de54342fe71474c5a8fe3eaeb89c8d7a086573635d6d7b6a4abbfdd61d84e7361697a903cdf1641385f0e
MISC metadata.xml 674 BLAKE2B a0d4f2c1989040b8cddb6ec87f0758bcd758e442b802f61a1f04da442288724ff296185e8c982247663fea70bf8a05f3cd1091033e4bf081ec3af9a03d623c2e SHA512 afcf2cfffad24226e64efc6116e01ec0750b8ba2df62871f090727e5300f98b8e166dcc7b025a29365cf83ea38575d8f63a705ebb478c83c416b8abf4ddb0fb3
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.6.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.6.ebuild
new file mode 100644
index 000000000000..035371628b77
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="amd64"
+IUSE="+cli doc"
+
+RDEPEND="dev-libs/metee:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}