summaryrefslogtreecommitdiff
path: root/dev-util/intel-graphics-system-controller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-02 23:47:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-02 23:47:16 +0100
commitd0855bf65db64f2452deea64fe76e06eaac9987c (patch)
tree42bdcad5ef28a19abde4b7e4ca89410b6b6e420a /dev-util/intel-graphics-system-controller
parent19ad4b65c8b02065c065c91941241f231f78246c (diff)
gentoo auto-resync : 02:10:2023 - 23:47:15
Diffstat (limited to 'dev-util/intel-graphics-system-controller')
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest2
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.13.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index 018d3c8938d5..13069ca50328 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1,3 +1,5 @@
+DIST intel-graphics-system-controller-0.8.13.tar.gz 188769 BLAKE2B 95e6929c85c299b23ba1996c1e365aad65b975c94852a427fa24b35d4a42fae1ff49ee941bc754543db52a3c79d59fbf27e635866721a51301f7623591c40012 SHA512 9ea523c168d80dadae863c89ce8abefd7510687b721f9e5a0573b28e157b7ecec9caf4717381a3bee29d59611c6f06b77f263f3973063112eb8ca3493d2bc720
DIST intel-graphics-system-controller-0.8.9.tar.gz 187575 BLAKE2B d4b1a95355e4effe09750cf21133641bd711ac8cdd72c4aba7cde8500ef5221012e20d0dbd7f6ac80e84efea58fe36c72a3c7bf967a9fb21504de9e5bad1752d SHA512 649764594f5043ae148949d2804308884bd93bbac83b3a2066339a0bfed64d4f7bca6a84d480fed0d98677d9fd0746520c8dfbcf03d0714bec2628c7b511bbf7
+EBUILD intel-graphics-system-controller-0.8.13.ebuild 1083 BLAKE2B c94314ffe0feb833b7de7931b4a073e61c57426c21c6017717ea2be91ef1fe3a0b7f36434d7f080eb82506d726f8bdbb474ead29c2c8ea661554cbee9a9ba8dc SHA512 136fb109fc8e5a19101c1002325fa052dfdcf8b3178354b980e923fa9f77cda161ffe651eddc29c8b97a43f8a3ba4e166f030b3e83a5e95a93dd4ff427c96cac
EBUILD intel-graphics-system-controller-0.8.9.ebuild 1082 BLAKE2B 83b9768bc3ddc68683a433c330d6fe4a59cf5c0dfb9e696fcf3c1911878d38bfc8a8aab637783a308ef4b11fb2f94016e3ac785ad2f79784ea469baccfd94ac1 SHA512 3b489ab94d6d9f863f754f1f721e4c04301079963b749a6064dc71d3b5de4a75a82837a7f8314912f7faa6e35f613d49b08f09bc569211a489498b66b6620d76
MISC metadata.xml 674 BLAKE2B a0d4f2c1989040b8cddb6ec87f0758bcd758e442b802f61a1f04da442288724ff296185e8c982247663fea70bf8a05f3cd1091033e4bf081ec3af9a03d623c2e SHA512 afcf2cfffad24226e64efc6116e01ec0750b8ba2df62871f090727e5300f98b8e166dcc7b025a29365cf83ea38575d8f63a705ebb478c83c416b8abf4ddb0fb3
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.13.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.13.ebuild
new file mode 100644
index 000000000000..ff1f3dca0bbb
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.13.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+cli doc"
+
+RDEPEND="dev-libs/metee:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}