summaryrefslogtreecommitdiff
path: root/dev-util/intel-graphics-system-controller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
commita4f9ab81d6cbfc3ff649dd3577e3efa700b47387 (patch)
tree1c6cf78322fbf3379d5b7e4f4b836a42c5fddd19 /dev-util/intel-graphics-system-controller
parenta4e37a9aeeef82eba5858dbc609f65b838b0f836 (diff)
gentoo auto-resync : 06:10:2022 - 01:20:42
Diffstat (limited to 'dev-util/intel-graphics-system-controller')
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest2
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.4.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index 17d70db95e1c..095fef4f70e1 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1,3 +1,5 @@
DIST intel-graphics-system-controller-0.8.0.tar.gz 166364 BLAKE2B 86a1aeb328554a7260c57bb4513dc236e34aa758b53d4d743562639326d22963742fe1ceca89df648187dfe8e7233c5306977241bb9d37e765d21f52d0073873 SHA512 a2fd38717cd1d02270c97eda20fe4294c634a0520293cdd396b93d474eed2ec903ed565a2d15d5e2671424000bb21c3f04b9812a4c050aa68383a75dee0281ef
+DIST intel-graphics-system-controller-0.8.4.tar.gz 173733 BLAKE2B c51f21bd2093d44c12ce10b4e5990a4428294093c6a8ccd90b01be30d918ac0898ea57b68ad004f4f477a7049e5060521c7fb1547d09f6e30cae8eab41090a69 SHA512 948c2043765c7a5b5dd9c350474725871601a76d292fd34c57c81b492945107ba2519b6a3f113cefed158adb7ac61164e85284be4683d1f48870650fdba969ad
EBUILD intel-graphics-system-controller-0.8.0.ebuild 1103 BLAKE2B d60e459e0179267530ecf72f3ddc02baeb04bf602b5a1edb83a514edab4f9854446d2124c2877c1ba27cc7442c7a129ae70f35d09764b52230810ac0c0dd1699 SHA512 1b8425012471d436a2d66254bf0cb802916821f2f9007eb1da4616b3c2fa11ea221330a8720c0dc31814718620bc909c40d1b910ff27895f52d02e3d54225f35
+EBUILD intel-graphics-system-controller-0.8.4.ebuild 1083 BLAKE2B 6a169b96f568cda5749b6135b62be8aaaa6d34afaf35d2fc196f828af2cad704e19e4cbc493afbf543c82a219861818244f24c90a6803e3668e2b3e1921aafff SHA512 787a73d397c422c38f13941bcb770508a69c6cf129a01e8dc7009813eee1890fcf16a7c099a2c0d2344fb00075e9f1d997d26dc61a76dd3678c5db2785ce17bc
MISC metadata.xml 674 BLAKE2B a0d4f2c1989040b8cddb6ec87f0758bcd758e442b802f61a1f04da442288724ff296185e8c982247663fea70bf8a05f3cd1091033e4bf081ec3af9a03d623c2e SHA512 afcf2cfffad24226e64efc6116e01ec0750b8ba2df62871f090727e5300f98b8e166dcc7b025a29365cf83ea38575d8f63a705ebb478c83c416b8abf4ddb0fb3
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.4.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.4.ebuild
new file mode 100644
index 000000000000..b874403f416f
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+cli doc"
+
+RDEPEND="dev-libs/metee:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}