summaryrefslogtreecommitdiff
path: root/dev-util/intel-graphics-system-controller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-15 22:41:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-15 22:41:20 +0100
commit7a0f8a92967dc1c6eab8d6f66ec476905009a287 (patch)
treeb73eed0b6ba49f9ca7e90538a00999ac22531f9c /dev-util/intel-graphics-system-controller
parent35d4e80ab08982deb97a95d1b47156c67b268492 (diff)
gentoo auto-resync : 15:07:2023 - 22:41:20
Diffstat (limited to 'dev-util/intel-graphics-system-controller')
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest2
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.9.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index ee82d8c8980a..397ec0ddeb06 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1,3 +1,5 @@
DIST intel-graphics-system-controller-0.8.7.tar.gz 181536 BLAKE2B 663ec335acdf96edd0c084d2c703687925233caa602e30ac1b189342d1e2a2d370975933fc34171703d3161b4c0f1637bb735fdc89bcd7ed6e5a41b49f946271 SHA512 cc0eabb67fed0c40ab1b0f9501bba87b56c1e97e66242df360036256a18d26912525e78e339c6d09c8d9cf557d00aac60cfb354961304ca41e746f4964705900
+DIST intel-graphics-system-controller-0.8.9.tar.gz 187575 BLAKE2B d4b1a95355e4effe09750cf21133641bd711ac8cdd72c4aba7cde8500ef5221012e20d0dbd7f6ac80e84efea58fe36c72a3c7bf967a9fb21504de9e5bad1752d SHA512 649764594f5043ae148949d2804308884bd93bbac83b3a2066339a0bfed64d4f7bca6a84d480fed0d98677d9fd0746520c8dfbcf03d0714bec2628c7b511bbf7
EBUILD intel-graphics-system-controller-0.8.7.ebuild 1082 BLAKE2B cfdc214379c9382625e5fb1d99184289ee97619d5f5feff1e19743d6b4677e31641318f6abffb9aae80881da8e43fe37f428dfad4efe8b649e8434de028614bf SHA512 d209cb49e46a5a0abc65cf8ed222bed624476e1dd7c846300f2843167357cee989e3bcdc8746944b22d7eb665c1a98930ba30eb3bc54e7ac45439e6059be23d5
+EBUILD intel-graphics-system-controller-0.8.9.ebuild 1083 BLAKE2B c94314ffe0feb833b7de7931b4a073e61c57426c21c6017717ea2be91ef1fe3a0b7f36434d7f080eb82506d726f8bdbb474ead29c2c8ea661554cbee9a9ba8dc SHA512 136fb109fc8e5a19101c1002325fa052dfdcf8b3178354b980e923fa9f77cda161ffe651eddc29c8b97a43f8a3ba4e166f030b3e83a5e95a93dd4ff427c96cac
MISC metadata.xml 674 BLAKE2B a0d4f2c1989040b8cddb6ec87f0758bcd758e442b802f61a1f04da442288724ff296185e8c982247663fea70bf8a05f3cd1091033e4bf081ec3af9a03d623c2e SHA512 afcf2cfffad24226e64efc6116e01ec0750b8ba2df62871f090727e5300f98b8e166dcc7b025a29365cf83ea38575d8f63a705ebb478c83c416b8abf4ddb0fb3
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.9.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.9.ebuild
new file mode 100644
index 000000000000..ff1f3dca0bbb
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+cli doc"
+
+RDEPEND="dev-libs/metee:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}