summaryrefslogtreecommitdiff
path: root/dev-util/intel-graphics-system-controller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-20 02:40:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-20 02:40:19 +0100
commit2d5fd1dd4910d46f935776f1f6f475de11367ef2 (patch)
tree42bc589da04de88a86fd2950f9c66360ee79328e /dev-util/intel-graphics-system-controller
parent54eca75a4e3e380e1d386f4d235baeb7d4ff332e (diff)
gentoo auto-resync : 20:07:2022 - 02:40:19
Diffstat (limited to 'dev-util/intel-graphics-system-controller')
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest2
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index c848fc23a051..72bebf10f3e9 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1,3 +1,5 @@
DIST intel-graphics-system-controller-0.6.0.tar.gz 146082 BLAKE2B e67b6d5064aece983d047e1f64e0477c613fb7bc0912c5173cc1c1588151703098e0429c790f25d78a76caab8663b80e9fc20f313be2318c2be2b30aa6ca06f5 SHA512 265716648b1c2a2e8164643eaf8a6cdac57953493d67c805ecfb9077b834e17b13693c56958c219083fc8e4f5fb3e9cafb64d6b3dd40d510434d4517ec945fc3
+DIST intel-graphics-system-controller-0.8.0.tar.gz 166364 BLAKE2B 86a1aeb328554a7260c57bb4513dc236e34aa758b53d4d743562639326d22963742fe1ceca89df648187dfe8e7233c5306977241bb9d37e765d21f52d0073873 SHA512 a2fd38717cd1d02270c97eda20fe4294c634a0520293cdd396b93d474eed2ec903ed565a2d15d5e2671424000bb21c3f04b9812a4c050aa68383a75dee0281ef
EBUILD intel-graphics-system-controller-0.6.0.ebuild 1103 BLAKE2B 8bc3afd859e66f76ae90ce229f9e2da04c16950dcea7305422677d53e7941c7d0e43682aaa2061c9375b84aad877f1c5c93cb0c326c0049d6ac76bca90dcf63f SHA512 c7d8525861f726323d23c9fd3544e2c092e8f34bd6c0113e8ef9b77e17d9c800d15f0b9160a5848daf4805dc314f3df17c05c72cfd918a5caedaa74e74b86393
+EBUILD intel-graphics-system-controller-0.8.0.ebuild 1104 BLAKE2B cc55f29c45a2c76139dd73eb069bdc821edfc63753e6d2e0c5164f8aba7d66c22ee104076ec62ee12a060c8671206ef57d67261fcd53685a09df8aadc9df9d5d SHA512 c081d1ff3d40a4a86db011d14d251044d12b8bbeb648503ead1a3b4a179fee34c9ac9d013c928de4b2358e8ba1064a738f8c93967a5e53607ab61ea949df7a15
MISC metadata.xml 674 BLAKE2B a0d4f2c1989040b8cddb6ec87f0758bcd758e442b802f61a1f04da442288724ff296185e8c982247663fea70bf8a05f3cd1091033e4bf081ec3af9a03d623c2e SHA512 afcf2cfffad24226e64efc6116e01ec0750b8ba2df62871f090727e5300f98b8e166dcc7b025a29365cf83ea38575d8f63a705ebb478c83c416b8abf4ddb0fb3
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.0.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.0.ebuild
new file mode 100644
index 000000000000..af442c4e311c
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+cli doc"
+
+RDEPEND="dev-libs/metee:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_ENUM="ON"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}