summaryrefslogtreecommitdiff
path: root/dev-util/intel-graphics-system-controller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 19:37:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 19:37:45 +0000
commit29eb24bde1b57b17d24078f22ee071e27f6b5348 (patch)
tree635e4a17793cef96c52a5d57d9bb4356672a347b /dev-util/intel-graphics-system-controller
parent1d6bc233e81d1ece6bcd5d781ed786208395d19d (diff)
gentoo auto-resync : 28:12:2023 - 19:37:44
Diffstat (limited to 'dev-util/intel-graphics-system-controller')
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest2
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.16.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index 185cbce35c6a..44aff4eb0024 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1,3 +1,5 @@
DIST intel-graphics-system-controller-0.8.13.tar.gz 188769 BLAKE2B 95e6929c85c299b23ba1996c1e365aad65b975c94852a427fa24b35d4a42fae1ff49ee941bc754543db52a3c79d59fbf27e635866721a51301f7623591c40012 SHA512 9ea523c168d80dadae863c89ce8abefd7510687b721f9e5a0573b28e157b7ecec9caf4717381a3bee29d59611c6f06b77f263f3973063112eb8ca3493d2bc720
+DIST intel-graphics-system-controller-0.8.16.tar.gz 192027 BLAKE2B fc97dffcffe53b92fa03b9fbcaa2f784f3fd33e4cdfa2f85548d2f6bea60bdf1868b003a45448829685fd961f9699534781de3ce43703a378168d50bf14927ce SHA512 105950a44c3b756fa4c23aa1590e2c0ae2f83af87660af14889641465433903a9e2973c8689338a716e67799098a762885933ba53c4a8de72ca4be3dbb134a84
EBUILD intel-graphics-system-controller-0.8.13-r1.ebuild 1090 BLAKE2B 9d6556f5b7b99b9ac14363d29f15f09fc3afd5a919e159936ca7c751cdafa238166f4108241a5364b74228d3041d6e50d175928d958204b2ca5e7074f8b47b74 SHA512 0cdbf19d5d385cbbf95d13734cc45841ef95dcd31a19e93c0abffe3114414d49cc836a2ce91c0fb8c1d721a8dc085aa838ac14ee578295b768e2083bed3bd55d
+EBUILD intel-graphics-system-controller-0.8.16.ebuild 1091 BLAKE2B e467d546e7026599548dd293c73806085c11fb85c018067e5bcf1681f177b1e695038ca1736989143fc8437d05ca95442e39e81858dc2c0ed10414e98e2e98e1 SHA512 69330997049dbc6b552cb2b236a2b81fff94b7d978d025a894952a275d64db8491be13681a53663e71298f7d5ca543faf6ccf854c39db81b194500a544f8e858
MISC metadata.xml 674 BLAKE2B a0d4f2c1989040b8cddb6ec87f0758bcd758e442b802f61a1f04da442288724ff296185e8c982247663fea70bf8a05f3cd1091033e4bf081ec3af9a03d623c2e SHA512 afcf2cfffad24226e64efc6116e01ec0750b8ba2df62871f090727e5300f98b8e166dcc7b025a29365cf83ea38575d8f63a705ebb478c83c416b8abf4ddb0fb3
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.16.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.16.ebuild
new file mode 100644
index 000000000000..ff1020e9561a
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.16.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+cli doc"
+
+RDEPEND=">=dev-libs/metee-3.2.4:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}