summaryrefslogtreecommitdiff
path: root/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild')
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild
deleted file mode 100644
index f38cef881cca..000000000000
--- a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="igsc"
-MY_P="${MY_PN}-${PV}"
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="Intel graphics system controller firmware update library"
-HOMEPAGE="https://github.com/intel/igsc"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+cli doc"
-
-RDEPEND="dev-libs/metee"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? (
- ${PYTHON_DEPS}
- app-doc/doxygen
- $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
- )
-"
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_CLI="$(usex cli)"
- -DENABLE_DOCS="$(usex doc)"
- -DENABLE_ENUM="ON"
- -DENABLE_PERF="OFF"
- -DENABLE_WERROR="OFF"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DENABLE_TESTS="OFF"
- )
-
- cmake_src_configure
-}