summaryrefslogtreecommitdiff
path: root/dev-util/intel-graphics-compiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 17:52:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 17:52:00 +0100
commitdd851ab76c56a249df7a0ec052acd90940bc014f (patch)
treeb9a0f7262f1fadcf70488c6c3c4dc644b502dc52 /dev-util/intel-graphics-compiler
parent713e25c0c3d1e5434ac60ec0549708ec2f744bb4 (diff)
gentoo auto-resync : 04:10:2023 - 17:51:59
Diffstat (limited to 'dev-util/intel-graphics-compiler')
-rw-r--r--dev-util/intel-graphics-compiler/Manifest2
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.15136.4-r1.ebuild (renamed from dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.15136.4.ebuild)6
2 files changed, 7 insertions, 1 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
index 21e95faf7dc6..0a71296f545e 100644
--- a/dev-util/intel-graphics-compiler/Manifest
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -4,5 +4,5 @@ AUX intel-graphics-compiler-1.0.9-no_Werror.patch 272 BLAKE2B 079fe334413dfddb76
DIST intel-graphics-compiler-1.0.14062.11.tar.gz 8415633 BLAKE2B 1dd65e37a6d2aa7539aa9d5700921ad9c75c3a5cb6a66870adbe9fac888eb16cc772574666f05ce02d165f8954c7b4ebbfbc2ed2008fdd86c5bbb472b95959ae SHA512 0fd2790997268b102ded0af47d4133cf251791c7ecd15758b378a0cdf6d6640d78cc68b2de0b003710a36da4d4750c7fa90eb2ac5aa1702164e46109fafd980d
DIST intel-graphics-compiler-1.0.15136.4.tar.gz 8942086 BLAKE2B 5008b9d255cd9923de73ef07929215b3e2c14d46c37ee0730d0c25ec1f109bd59fa1178cd7e085cf9b7009cf820cdf29a2a880b9f1c1528f494c300d21535732 SHA512 22c676bec940c91bae0a5cd36f904febbab2e4e60dc8379f2068adb9b1cd2de8d37aa1c66dec2616f1a761e862b58676aa484cdcdf7bdd002222bdc337571bc8
EBUILD intel-graphics-compiler-1.0.14062.11.ebuild 2655 BLAKE2B 4c078439167bfbd637aa2ae058e3fbe0b7a274217a2f8af9778e0e75bbb727a4f15427aaf849446a50ef30bba4e82e587072e97e2c9369588f6ec91b4dfc3d3e SHA512 0d0f40c58e1751e0e15c2337c3b7f71f6c40afca1e31b93a1fbb13efd8c14666d80ae46a2fc9007cb02b7cdaed085a37e6ebbbab9daa71ef12d643927a8845f9
-EBUILD intel-graphics-compiler-1.0.15136.4.ebuild 2656 BLAKE2B d04b7d39582b235de0243ae5e32aff30e4ba23940c3af8b11a7990264b9a6a2801fb9f5e9e20246e4fb3f7fa8a4c8eda5b471c2d027566578775bff172cb18d9 SHA512 d454459105cf00e91300df5c4b6be0430df4ada2399c0ac3249210258b15892ebd14ab9a7c163f108c2e10903cf0812aefe8ad1f90c8bf9186434c7e87d4fe86
+EBUILD intel-graphics-compiler-1.0.15136.4-r1.ebuild 2830 BLAKE2B 21429b8daca0e017c6eac88fca960af808cbdc310a4354a05c1f58dcc85cd5e29ab4ba03738c952b3dfb11f26ed2b92713626487b39673f46a4f5531da8d0b04 SHA512 89cd6d90be025a5b8d31d43d462eed4f63e2728dafbc93c8f2645882a79cf4bae07ae6abbc87111a262c8ec6401ca4cf95f2a7d042c14f86c23580fa97f7129b
MISC metadata.xml 682 BLAKE2B c5e74bbb1a5aca5eed7cb75a19820dc9d78d7ef7a15687924d16863a82a535403ca67103ac458d4b86f380244e726a3bd20fb496f8048f999abdf89950a7092c SHA512 d5a35d2104e9aa5caaf903a9f61ca8a8c4f8b5bff3e993c9964dd63196e64b88e3e7bde2e0cff9dcee9c66bdda0cabb43c5ac8c121796626bb0e7f4013929fb3
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.15136.4.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.15136.4-r1.ebuild
index 1d957af7dd89..4af5fe6fad51 100644
--- a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.15136.4.ebuild
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.15136.4-r1.ebuild
@@ -35,10 +35,15 @@ DEPEND="
RDEPEND="${DEPEND}"
BDEPEND="
+ $(python_gen_any_dep 'dev-python/mako[${PYTHON_USEDEP}]')
=sys-devel/lld-${LLVM_MAX_SLOT}*
${PYTHON_DEPS}
"
+python_check_deps() {
+ python_has_version "dev-python/mako[${PYTHON_USEDEP}]"
+}
+
PATCHES=(
"${FILESDIR}/${PN}-1.0.9-no_Werror.patch"
"${FILESDIR}/${PN}-1.0.8173-opencl-clang_version.patch"
@@ -86,6 +91,7 @@ src_configure() {
-DIGC_OPTION__SPIRV_TOOLS_MODE="Prebuilds"
-DIGC_OPTION__SPIRV_TRANSLATOR_MODE="Prebuilds"
$(usex vc '-DIGC_OPTION__VC_INTRINSICS_MODE=Prebuilds' '')
+ -DPYTHON_EXECUTABLE="${PYTHON}"
-DINSTALL_GENX_IR="ON"
-DSPIRVLLVMTranslator_INCLUDE_DIR="${EPREFIX}/usr/lib/llvm/${LLVM_MAX_SLOT}/include/LLVMSPIRVLib"
-Wno-dev