summaryrefslogtreecommitdiff
path: root/dev-util/intel-graphics-compiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-util/intel-graphics-compiler
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-util/intel-graphics-compiler')
-rw-r--r--dev-util/intel-graphics-compiler/Manifest3
-rw-r--r--dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.4111-opencl-clang_version.patch27
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.4111.ebuild2
3 files changed, 31 insertions, 1 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
index 4d4182497b9b..71a4b9d1054b 100644
--- a/dev-util/intel-graphics-compiler/Manifest
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -1,4 +1,5 @@
+AUX intel-graphics-compiler-1.0.4111-opencl-clang_version.patch 1567 BLAKE2B cef900deb559e251e7fce91b8b8558e5eff846d5bab0153edb6d01ee29bdd0fd4c8dfcf3f3d732a23c357eebb119a4b833205f6e8526ef612069cec165395bf6 SHA512 984a3f26bd16d2d2db0608338f498ebefbbadb6b75552d3c3eaa0fea3456bf52e5ed0c57bedbd144e1d72bf6dea132fb21fe0d8cbca008ddd6b5456352143942
AUX intel-graphics-compiler-1.0.9-no_Werror.patch 272 BLAKE2B 079fe334413dfddb7681940f2a8920a365e8e72526cfc09ea1c7d218e8b19468f80ea9a215be125b441ee5238d7856b8dec02ebfc4bfd76b1850aa9917da35ef SHA512 d3d27943e84e228b480172b4fe91ba9aed8bb1c98700eb8c8beebafb7f1cc6265279031f56181e67eff74f55e1bbc8ee24bdc4d14fc1200c5aff670ef019410d
DIST intel-graphics-compiler-1.0.4111.tar.gz 5781246 BLAKE2B 6fe47422b31b0c73d24c3cef1265772927a57751bf5648f862f7c73528f2174268fdb2271c30c49ab038b4dfbe530bc088fe727e66babc5db0a41759e7212733 SHA512 8f589ee83a27b7a8f5abcd008e36a73fb704c20c1ae17e1ef265c59641768b75a0a08f2d6f80355442fff7625154603db3ebe9be0a4ba702b45e85db434f8110
-EBUILD intel-graphics-compiler-1.0.4111.ebuild 1663 BLAKE2B 5bf7753c427356e80cf79221fedee6dbb61670ac86269787bdfb37fa6b018eb0dfeb0925b7b127d44144e89784fef8052ea5f438df41ae4a3aa0b107c4b8b4a9 SHA512 a1501c953a613beafc2b22f763fbf515cdebea1d0b075cf77f1fedde12418a6a2c573eab71b7e847685d9b96a859a8e78a001ac14923656655516d45fb92c050
+EBUILD intel-graphics-compiler-1.0.4111.ebuild 1759 BLAKE2B 183287bc5e3d3f93406946fed4f96b76ca57c7aec205f03ef45257a17e2099235293e549e6a8d467dc0d15773b494093092121c6b7f8c76dc402cbe5f3766b27 SHA512 a7b1fed4d705a363debebee0e8ca847b4db5b4a17d423ddb6e78cf8f82be3ce06bd2c497545b4b7193605df35c234441585de2e84276d08f0f01bee5cec03acf
MISC metadata.xml 340 BLAKE2B 6c0e5d932084dffd300a1dc70b29eb0871dfe2187ed8591a5a2f8cba001bf681e908c58a6f9471f7b08842ff538365258305da91004ed63ff97314a07fda529f SHA512 d24016b4ae0ffb05be475f86bb8d72ab4a85475655f409b8826dcd69726e048aa048e321f26ac36f2f52aec40abbfa66a95354a711332df94dc3e57e6c396a0c
diff --git a/dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.4111-opencl-clang_version.patch b/dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.4111-opencl-clang_version.patch
new file mode 100644
index 000000000000..8996466275c9
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.4111-opencl-clang_version.patch
@@ -0,0 +1,27 @@
+--- a/IGC/BiFModule/CMakeLists.txt
++++ b/IGC/BiFModule/CMakeLists.txt
+@@ -160,20 +160,10 @@
+
+ if(UNIX)
+ if(NOT ${CCLANG_BUILD_INTREE_LLVM})
+- # Get common clang library soname
+- get_target_property(CCLANG_LIB_PATH opencl-clang-lib "IMPORTED_LOCATION")
+- execute_process(
+- COMMAND readelf -d ${CCLANG_LIB_PATH}
+- OUTPUT_VARIABLE CCLANG_READELF_CALL)
+- string(REGEX MATCH "\\[${COMMON_CLANG_LIB_FULL_NAME}\\.([0-9](\\.[0-9]*)*[a-zA-Z0-9]*)\\]" CCLANG_SONAME_VERSION "${CCLANG_READELF_CALL}")
+- set(CCLANG_SONAME_VERSION "${CMAKE_MATCH_1}")
+-
+- # Check if common clang library is newer than 5.0.0 version on which we have SPIR-V support
+- if("${CCLANG_SONAME_VERSION}" VERSION_GREATER "5.0.0")
+- set_property(TARGET opencl-clang-lib PROPERTY "IMPORTED_SONAME" "${COMMON_CLANG_LIB_FULL_NAME}.${CCLANG_SONAME_VERSION}")
+- else()
+- message(FATAL_ERROR "[IGC\\BiFModule] : Version ${CCLANG_SONAME_VERSION} of library ${COMMON_CLANG_LIB_FULL_NAME} is below version 5.0.0 (where it's starts support of SPIR-V), please upgrade this library at least to version 5.0.0")
+- endif()
++ # Workaround for https://bugs.gentoo.org/739138 : instead of checking
++ # the version of opencl-clang, have ebuilds set CCLANG_SONAME_VERSION
++ # for us.
++ set_property(TARGET opencl-clang-lib PROPERTY "IMPORTED_SONAME" "${COMMON_CLANG_LIB_FULL_NAME}.${CCLANG_SONAME_VERSION}")
+ endif()
+ if (NOT CCLANG_FROM_SYSTEM)
+ install(FILES $<TARGET_FILE:opencl-clang-lib> DESTINATION ${CMAKE_INSTALL_FULL_LIBDIR} COMPONENT igc-opencl)
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.4111.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.4111.ebuild
index 3bdf70d334d3..b5113c4912d6 100644
--- a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.4111.ebuild
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.4111.ebuild
@@ -27,6 +27,7 @@ RDEPEND="${COMMON}"
PATCHES=(
"${FILESDIR}"/${PN}-1.0.9-no_Werror.patch
+ "${FILESDIR}"/${PN}-1.0.4111-opencl-clang_version.patch
)
S="${WORKDIR}"/${PN}-igc-${PV}
@@ -45,6 +46,7 @@ multilib_src_configure() {
use debug || append-cppflags -DNDEBUG
local mycmakeargs=(
+ -DCCLANG_SONAME_VERSION=${llvm_slot}
-DCMAKE_LIBRARY_PATH=$(get_llvm_prefix ${llvm_slot})/$(get_libdir)
-DIGC_OPTION__FORCE_SYSTEM_LLVM=ON
-DIGC_PREFERRED_LLVM_VERSION=${llvm_slot}